{"id":"CVE-2025-31480","state":"PUBLISHED","title":"aiven-extras allows PostgreSQL Privilege Escalation through format function","description":"aiven-extras is a PostgreSQL extension. This is a privilege escalation vulnerability, allowing elevation to superuser inside PostgreSQL databases that use the aiven-extras package. The vulnerability leverages the format function not being schema-prefixed. Affected users should install 1.1.16 and ensure they run the latest version issuing ALTER EXTENSION aiven_extras UPDATE TO '1.1.16' after installing it. This needs to happen in each database aiven_extras has been installed in.","publishedAt":"2025-04-04T14:49:30.863Z","updatedAt":"2025-04-04T14:57:54.321Z","severity":{"score":9.1,"label":"Critical","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H","source":"GitHub_M"},"assigner":"GitHub_M","products":["aiven aiven-extras"],"affected":[{"vendor":"aiven","product":"aiven-extras","versions":[{"version":"< 1.1.16","status":"affected"}]}],"references":["https://github.com/aiven/aiven-extras/security/advisories/GHSA-33xh-jqgf-6627","https://github.com/aiven/aiven-extras/commit/77b5f19a0c1d196bc741ff5c774f85fe7ca3063b"],"weaknesses":["CWE-426"],"ingestedAt":"2026-10-29T20:08:55.257Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2025/31xxx/CVE-2025-31480.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2025-31480","state":"PUBLISHED","datePublished":"2025-04-04T14:49:30.863Z","dateUpdated":"2025-04-04T14:57:54.321Z","assignerShortName":"GitHub_M","assignerOrgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateReserved":"2025-03-28T13:36:51.297Z"},"containers":{"cna":{"title":"aiven-extras allows PostgreSQL Privilege Escalation through format function","descriptions":[{"lang":"en","value":"aiven-extras is a PostgreSQL extension. This is a privilege escalation vulnerability, allowing elevation to superuser inside PostgreSQL databases that use the aiven-extras package. The vulnerability leverages the format function not being schema-prefixed. Affected users should install 1.1.16 and ensure they run the latest version issuing ALTER EXTENSION aiven_extras UPDATE TO '1.1.16' after installing it. This needs to happen in each database aiven_extras has been installed in."}],"affected":[{"vendor":"aiven","product":"aiven-extras","versions":[{"version":"< 1.1.16","status":"affected"}]}],"references":[{"url":"https://github.com/aiven/aiven-extras/security/advisories/GHSA-33xh-jqgf-6627","name":"https://github.com/aiven/aiven-extras/security/advisories/GHSA-33xh-jqgf-6627","tags":["x_refsource_CONFIRM"]},{"url":"https://github.com/aiven/aiven-extras/commit/77b5f19a0c1d196bc741ff5c774f85fe7ca3063b","name":"https://github.com/aiven/aiven-extras/commit/77b5f19a0c1d196bc741ff5c774f85fe7ca3063b","tags":["x_refsource_MISC"]}],"metrics":[{"cvssV3_1":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"HIGH","baseScore":9.1,"baseSeverity":"CRITICAL","confidentialityImpact":"HIGH","integrityImpact":"HIGH","privilegesRequired":"HIGH","scope":"CHANGED","userInteraction":"NONE","vectorString":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H","version":"3.1"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-426","lang":"en","description":"CWE-426: Untrusted Search Path","type":"CWE"}]}],"providerMetadata":{"shortName":"GitHub_M","orgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateUpdated":"2025-04-04T14:49:30.863Z"},"source":{"advisory":"GHSA-33xh-jqgf-6627","discovery":"UNKNOWN"}},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-04-04T14:57:39.462536Z","id":"CVE-2025-31480","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"total"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-04-04T14:57:54.321Z"}}]}}}