{"id":"CVE-2025-3101","state":"PUBLISHED","title":"Configurator Theme Core <= 1.4.7 - Authenticated (Subscriber+) Privilege Escalation","description":"The Configurator Theme Core plugin for WordPress is vulnerable to privilege escalation in all versions up to, and including, 1.4.7. This is due to the plugin not properly validating user meta fields prior to updating them in the database. This makes it possible for authenticated attackers, with Subscriber-level access and above, to change escalate their privileges to Administrator.","publishedAt":"2025-04-24T08:23:48.158Z","updatedAt":"2026-04-08T16:53:03.335Z","severity":{"score":8.8,"label":"High","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","source":"Wordfence"},"assigner":"Wordfence","products":["wp-configurator Configurator Theme Core"],"affected":[{"vendor":"wp-configurator","product":"Configurator Theme Core","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"1.4.7","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/535aa061-479f-415e-bee6-3151c42b917e?source=cve","https://themeforest.net/item/configurator-woocommerce-wordpress-theme/20474230"],"weaknesses":["CWE-269"],"ingestedAt":"2026-10-29T20:09:09.358Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2025/3xxx/CVE-2025-3101.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2025-3101","state":"PUBLISHED","datePublished":"2025-04-24T08:23:48.158Z","dateUpdated":"2026-04-08T16:53:03.335Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2025-04-01T17:05:36.045Z"},"containers":{"cna":{"title":"Configurator Theme Core <= 1.4.7 - Authenticated (Subscriber+) Privilege Escalation","descriptions":[{"lang":"en","value":"The Configurator Theme Core plugin for WordPress is vulnerable to privilege escalation in all versions up to, and including, 1.4.7. This is due to the plugin not properly validating user meta fields prior to updating them in the database. This makes it possible for authenticated attackers, with Subscriber-level access and above, to change escalate their privileges to Administrator."}],"affected":[{"vendor":"wp-configurator","product":"Configurator Theme Core","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"1.4.7","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/535aa061-479f-415e-bee6-3151c42b917e?source=cve"},{"url":"https://themeforest.net/item/configurator-woocommerce-wordpress-theme/20474230"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","baseScore":8.8,"baseSeverity":"HIGH"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-269","lang":"en","description":"CWE-269 Improper Privilege Management","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T16:53:03.335Z"},"credits":[{"lang":"en","type":"finder","value":"Tonn"}],"timeline":[{"time":"2025-04-23T19:36:21.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-04-24T13:39:54.697513Z","id":"CVE-2025-3101","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"total"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-04-24T15:22:51.170Z"}}]}}}