{"id":"CVE-2025-3064","state":"PUBLISHED","title":"WPFront User Role Editor <= 4.2.1 - Cross-Site Request Forgery to Privilege Escalation via whitelist_options Function","description":"The WPFront User Role Editor plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 4.2.1. This is due to missing or incorrect nonce validation on the whitelist_options() function. This makes it possible for unauthenticated attackers to update the default role option that can be leveraged for privilege escalation via a forged request granted they can trick a site administrator into performing an action such as clicking on a link. This is only exploitable on multisite instances.","publishedAt":"2025-04-08T08:22:09.698Z","updatedAt":"2026-04-08T17:32:04.038Z","severity":{"score":8.8,"label":"High","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","source":"Wordfence"},"assigner":"Wordfence","products":["syammohanm WPFront User Role Editor"],"affected":[{"vendor":"syammohanm","product":"WPFront User Role Editor","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"4.2.1","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/efc7ad9f-714e-474c-87e8-ecbbdfabd550?source=cve","https://plugins.trac.wordpress.org/browser/wpfront-user-role-editor/trunk/includes/users/class-user-profile.php#L104","https://plugins.trac.wordpress.org/browser/wpfront-user-role-editor/trunk/includes/users/class-user-profile.php#L399","https://wordpress.org/plugins/wpfront-user-role-editor/#developers","https://plugins.trac.wordpress.org/changeset/3266542/#file142"],"weaknesses":["CWE-352"],"ingestedAt":"2026-10-29T20:09:09.358Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2025/3xxx/CVE-2025-3064.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2025-3064","state":"PUBLISHED","datePublished":"2025-04-08T08:22:09.698Z","dateUpdated":"2026-04-08T17:32:04.038Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2025-03-31T22:25:31.869Z"},"containers":{"cna":{"title":"WPFront User Role Editor <= 4.2.1 - Cross-Site Request Forgery to Privilege Escalation via whitelist_options Function","descriptions":[{"lang":"en","value":"The WPFront User Role Editor plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 4.2.1. This is due to missing or incorrect nonce validation on the whitelist_options() function. This makes it possible for unauthenticated attackers to update the default role option that can be leveraged for privilege escalation via a forged request granted they can trick a site administrator into performing an action such as clicking on a link. This is only exploitable on multisite instances."}],"affected":[{"vendor":"syammohanm","product":"WPFront User Role Editor","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"4.2.1","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/efc7ad9f-714e-474c-87e8-ecbbdfabd550?source=cve"},{"url":"https://plugins.trac.wordpress.org/browser/wpfront-user-role-editor/trunk/includes/users/class-user-profile.php#L104"},{"url":"https://plugins.trac.wordpress.org/browser/wpfront-user-role-editor/trunk/includes/users/class-user-profile.php#L399"},{"url":"https://wordpress.org/plugins/wpfront-user-role-editor/#developers"},{"url":"https://plugins.trac.wordpress.org/changeset/3266542/#file142"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","baseScore":8.8,"baseSeverity":"HIGH"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-352","lang":"en","description":"CWE-352 Cross-Site Request Forgery (CSRF)","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T17:32:04.038Z"},"credits":[{"lang":"en","type":"finder","value":"Matthew Rollings"},{"lang":"en","type":"finder","value":"Brian Sans-Souci"}],"timeline":[{"time":"2025-04-07T19:49:38.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-04-08T13:40:34.443378Z","id":"CVE-2025-3064","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"total"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-04-08T13:40:51.320Z"}}]}}}