{"id":"CVE-2025-27801","state":"PUBLISHED","title":"Stored Cross-Site Scripting in Episerver Content Management System (CMS) Media Selection Preview","description":"The Episerver Content Management System (CMS) by Optimizely was affected by multiple Stored Cross-Site Scripting (XSS) vulnerabilities. This allowed an authenticated attacker to execute malicious JavaScript code in the victim's browser.\n\n\n\nContentReference properties, which could be used in the \"Edit\" section of the CMS, offered an upload functionality for documents. These documents could later be used as displayed content on the page. It was possible to upload SVG files that include malicious JavaScript code that would be executed if a user visited the direct URL of the preview image. Attackers needed at least the role \"WebEditor\" in order to exploit this issue.\n\n\n\n\n\n\n\nAffected products: Version 11.X: EPiServer.CMS.Core (<11.21.4) with EPiServer.CMS.UI (<11.37.5), Version 12.X: EPiServer.CMS.Core (<12.22.1) with EPiServer.CMS.UI (<11.37.3)","publishedAt":"2025-07-28T08:40:15.815Z","updatedAt":"2025-11-03T19:46:25.984Z","severity":{"score":4.6,"label":"Medium","version":"4.0","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:A/VC:N/VI:L/VA:L/SC:L/SI:L/SA:N","source":"SEC-VLab"},"assigner":"SEC-VLab","products":["Optimizely Episerver Content Management System (CMS)"],"affected":[{"vendor":"Optimizely","product":"Episerver Content Management System (CMS)","defaultStatus":"unaffected","versions":[{"version":"11.x","status":"affected","lessThan":"11.21.4","versionType":"custom"},{"version":"12.x","status":"affected","lessThan":"12.22.1","versionType":"custom"}],"modules":["EPiServer.CMS.Core"]}],"references":["https://api.nuget.optimizely.com/packages/episerver.cms.core/11.21.4#","https://api.nuget.optimizely.com/packages/episerver.cms.core/12.22.1#","https://r.sec-consult.com/optimizely","http://seclists.org/fulldisclosure/2025/Aug/18"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T20:08:47.682Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2025/27xxx/CVE-2025-27801.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2025-27801","state":"PUBLISHED","datePublished":"2025-07-28T08:40:15.815Z","dateUpdated":"2025-11-03T19:46:25.984Z","assignerShortName":"SEC-VLab","assignerOrgId":"551230f0-3615-47bd-b7cc-93e92e730bbf","dateReserved":"2025-03-07T06:46:34.309Z"},"containers":{"cna":{"title":"Stored Cross-Site Scripting in Episerver Content Management System (CMS) Media Selection Preview","descriptions":[{"lang":"en","value":"The Episerver Content Management System (CMS) by Optimizely was affected by multiple Stored Cross-Site Scripting (XSS) vulnerabilities. This allowed an authenticated attacker to execute malicious JavaScript code in the victim's browser.\n\n\n\nContentReference properties, which could be used in the \"Edit\" section of the CMS, offered an upload functionality for documents. These documents could later be used as displayed content on the page. It was possible to upload SVG files that include malicious JavaScript code that would be executed if a user visited the direct URL of the preview image. Attackers needed at least the role \"WebEditor\" in order to exploit this issue.\n\n\n\n\n\n\n\nAffected products: Version 11.X: EPiServer.CMS.Core (<11.21.4) with EPiServer.CMS.UI (<11.37.5), Version 12.X: EPiServer.CMS.Core (<12.22.1) with EPiServer.CMS.UI (<11.37.3)"}],"affected":[{"vendor":"Optimizely","product":"Episerver Content Management System (CMS)","defaultStatus":"unaffected","versions":[{"version":"11.x","status":"affected","lessThan":"11.21.4","versionType":"custom"},{"version":"12.x","status":"affected","lessThan":"12.22.1","versionType":"custom"}],"modules":["EPiServer.CMS.Core"]}],"references":[{"url":"https://api.nuget.optimizely.com/packages/episerver.cms.core/11.21.4#","tags":["patch"]},{"url":"https://api.nuget.optimizely.com/packages/episerver.cms.core/12.22.1#","tags":["patch"]},{"url":"https://r.sec-consult.com/optimizely","tags":["third-party-advisory"]}],"metrics":[{"cvssV4_0":{"Automatable":"NOT_DEFINED","Recovery":"NOT_DEFINED","Safety":"NOT_DEFINED","attackComplexity":"LOW","attackRequirements":"NONE","attackVector":"NETWORK","baseScore":4.6,"baseSeverity":"MEDIUM","privilegesRequired":"HIGH","providerUrgency":"NOT_DEFINED","subAvailabilityImpact":"NONE","subConfidentialityImpact":"LOW","subIntegrityImpact":"LOW","userInteraction":"ACTIVE","valueDensity":"NOT_DEFINED","vectorString":"CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:A/VC:N/VI:L/VA:L/SC:L/SI:L/SA:N","version":"4.0","vulnAvailabilityImpact":"LOW","vulnConfidentialityImpact":"NONE","vulnIntegrityImpact":"LOW","vulnerabilityResponseEffort":"NOT_DEFINED"},"format":"CVSS","scenarios":[{"lang":"en","value":"GENERAL"}]},{"cvssV3_1":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"NONE","baseScore":4.8,"baseSeverity":"MEDIUM","confidentialityImpact":"LOW","integrityImpact":"LOW","privilegesRequired":"HIGH","scope":"CHANGED","userInteraction":"REQUIRED","vectorString":"CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"format":"CVSS","scenarios":[{"lang":"en","value":"GENERAL"}]}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","description":"CWE-79 Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting')","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"SEC-VLab","orgId":"551230f0-3615-47bd-b7cc-93e92e730bbf","dateUpdated":"2025-07-29T09:37:21.584Z"},"credits":[{"lang":"en","type":"finder","value":"Kai Zimmermann, SEC Consult Vulnerability Lab"},{"lang":"en","type":"finder","value":"Felix Beie, SEC Consult Vulnerability Lab"}],"impacts":[{"capecId":"CAPEC-63","descriptions":[{"lang":"en","value":"CAPEC-63 Cross-Site Scripting (XSS)"}]}],"solutions":[{"lang":"en","supportingMedia":[{"base64":false,"type":"text/html","value":"The vendor already provides a security patch (updated packages) which should be \ninstalled immediately.<br>"}],"value":"The vendor already provides a security patch (updated packages) which should be \ninstalled immediately."}],"source":{"discovery":"UNKNOWN"},"x_generator":{"engine":"Vulnogram 0.2.0"}},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-07-28T16:48:16.253770Z","id":"CVE-2025-27801","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-07-28T16:49:08.730Z"}},{"title":"CVE Program Container","references":[{"url":"http://seclists.org/fulldisclosure/2025/Aug/18"}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2025-11-03T19:46:25.984Z"}}]}}}