{"id":"CVE-2025-27371","state":"PUBLISHED","title":"In certain IETF OAuth 2.0-related specifications, when the JSON Web Token Profile for OAuth 2.0 Client Authentication mechanism is used, there are ambiguities in the audience value","description":"In certain IETF OAuth 2.0-related specifications, when the JSON Web Token Profile for OAuth 2.0 Client Authentication mechanism is used, there are ambiguities in the audience values of JWTs sent to authorization servers. The affected RFCs may include RFC 7523, and also RFC 7521, RFC 7522, RFC 9101 (JAR), and RFC 9126 (PAR).","publishedAt":"2025-03-03T00:00:00.000Z","updatedAt":"2025-04-25T14:42:06.366Z","severity":{"score":6.9,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:H/A:N","source":"mitre"},"assigner":"mitre","products":["IETF RFC 7523"],"affected":[{"vendor":"IETF","product":"RFC 7523","defaultStatus":"unknown","versions":[{"version":"7523","status":"affected","versionType":"custom"}]}],"references":["https://openid.net/wp-content/uploads/2025/01/OIDF-Responsible-Disclosure-Notice-on-Security-Vulnerability-for-private_key_jwt.pdf","https://openid.net/notice-of-a-security-vulnerability/","https://talks.secworkshop.events/osw2025/talk/R8D9BS/","https://github.com/OWASP/ASVS/issues/2678","https://eprint.iacr.org/2025/629"],"weaknesses":["CWE-305"],"ingestedAt":"2026-10-29T20:08:47.682Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2025/27xxx/CVE-2025-27371.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2025-27371","state":"PUBLISHED","datePublished":"2025-03-03T00:00:00.000Z","dateUpdated":"2025-04-25T14:42:06.366Z","assignerShortName":"mitre","assignerOrgId":"8254265b-2729-46b6-b9e3-3dfca2d5bfca","dateReserved":"2025-02-23T00:00:00.000Z"},"containers":{"cna":{"descriptions":[{"lang":"en","value":"In certain IETF OAuth 2.0-related specifications, when the JSON Web Token Profile for OAuth 2.0 Client Authentication mechanism is used, there are ambiguities in the audience values of JWTs sent to authorization servers. The affected RFCs may include RFC 7523, and also RFC 7521, RFC 7522, RFC 9101 (JAR), and RFC 9126 (PAR)."}],"affected":[{"vendor":"IETF","product":"RFC 7523","defaultStatus":"unknown","versions":[{"version":"7523","status":"affected","versionType":"custom"}]}],"references":[{"url":"https://openid.net/wp-content/uploads/2025/01/OIDF-Responsible-Disclosure-Notice-on-Security-Vulnerability-for-private_key_jwt.pdf"},{"url":"https://openid.net/notice-of-a-security-vulnerability/"},{"url":"https://talks.secworkshop.events/osw2025/talk/R8D9BS/"},{"url":"https://github.com/OWASP/ASVS/issues/2678"},{"url":"https://eprint.iacr.org/2025/629"}],"metrics":[{"cvssV3_1":{"version":"3.1","baseScore":6.9,"baseSeverity":"MEDIUM","vectorString":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:H/A:N"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-305","description":"CWE-305 Authentication Bypass by Primary Weakness","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"mitre","orgId":"8254265b-2729-46b6-b9e3-3dfca2d5bfca","dateUpdated":"2025-04-25T14:42:06.366Z"},"x_generator":{"engine":"enrichogram 0.0.1"}},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-03-04T16:49:31.778471Z","id":"CVE-2025-27371","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-03-04T16:49:57.268Z"}}]}}}