{"id":"CVE-2025-2330","state":"PUBLISHED","title":"All-in-One Addons for Elementor – WidgetKit <= 2.5.4 - Authenticated (Contributor+) Stored Cross-Site Scripting via button+modal Widget","description":"The All-in-One Addons for Elementor – WidgetKit plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'button+modal' widget in all versions up to, and including, 2.5.4 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.","publishedAt":"2025-07-02T09:23:24.595Z","updatedAt":"2026-04-08T17:04:14.785Z","severity":{"score":6.4,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["shamsbd71 All-in-One Addons for Elementor – WidgetKit"],"affected":[{"vendor":"shamsbd71","product":"All-in-One Addons for Elementor – WidgetKit","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"2.5.4","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/83d5337b-8c06-41ee-b18c-2c39150a7f30?source=cve","https://plugins.trac.wordpress.org/browser/widgetkit-for-elementor/trunk/elements/button-modal/template/view.php#L86","https://wordpress.org/plugins/widgetkit-for-elementor/#developers","https://plugins.trac.wordpress.org/changeset/3283765/widgetkit-for-elementor/tags/2.5.5/elements/button-modal/template/view.php"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T20:08:55.257Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2025/2xxx/CVE-2025-2330.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2025-2330","state":"PUBLISHED","datePublished":"2025-07-02T09:23:24.595Z","dateUpdated":"2026-04-08T17:04:14.785Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2025-03-14T21:21:22.902Z"},"containers":{"cna":{"title":"All-in-One Addons for Elementor – WidgetKit <= 2.5.4 - Authenticated (Contributor+) Stored Cross-Site Scripting via button+modal Widget","descriptions":[{"lang":"en","value":"The All-in-One Addons for Elementor – WidgetKit plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'button+modal' widget in all versions up to, and including, 2.5.4 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page."}],"affected":[{"vendor":"shamsbd71","product":"All-in-One Addons for Elementor – WidgetKit","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"2.5.4","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/83d5337b-8c06-41ee-b18c-2c39150a7f30?source=cve"},{"url":"https://plugins.trac.wordpress.org/browser/widgetkit-for-elementor/trunk/elements/button-modal/template/view.php#L86"},{"url":"https://wordpress.org/plugins/widgetkit-for-elementor/#developers"},{"url":"https://plugins.trac.wordpress.org/changeset/3283765/widgetkit-for-elementor/tags/2.5.5/elements/button-modal/template/view.php"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","baseScore":6.4,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","lang":"en","description":"CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T17:04:14.785Z"},"credits":[{"lang":"en","type":"finder","value":"Craig Smith"}],"timeline":[{"time":"2025-07-01T20:38:15.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-07-02T13:02:13.591925Z","id":"CVE-2025-2330","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-07-02T13:14:21.969Z"}}]}}}