{"id":"CVE-2025-23209","state":"PUBLISHED","title":"Potential RCE with a compromised security key in craft/cms","description":"Craft is a flexible, user-friendly CMS for creating custom digital experiences on the web and beyond. This is an remote code execution (RCE) vulnerability that affects Craft 4 and 5 installs where your security key has already been compromised. Anyone running an unpatched version of Craft with a compromised security key is affected. This vulnerability has been patched in Craft 5.5.8 and 4.13.8. Users who cannot update to a patched version, should rotate their security keys and ensure their privacy to help migitgate the issue.","publishedAt":"2025-01-18T00:32:54.954Z","updatedAt":"2026-02-26T19:09:05.707Z","severity":{"score":8.1,"label":"High","version":"3.1","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H","source":"GitHub_M"},"assigner":"GitHub_M","products":["craftcms cms"],"affected":[{"vendor":"craftcms","product":"cms","versions":[{"version":">= 5.0.0-RC1, < 5.5.5","status":"affected"},{"version":">= 4.0.0-RC1, < 4.13.8","status":"affected"}]}],"references":["https://github.com/craftcms/cms/security/advisories/GHSA-x684-96hh-833x","https://github.com/craftcms/cms/commit/e59e22b30c9dd39e5e2c7fe02c147bcbd004e603","https://craftcms.com/knowledge-base/securing-craft#keep-your-secrets-secret","https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2025-23209"],"weaknesses":["CWE-94"],"ingestedAt":"2026-10-29T20:08:39.238Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2025/23xxx/CVE-2025-23209.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2025-23209","state":"PUBLISHED","datePublished":"2025-01-18T00:32:54.954Z","dateUpdated":"2026-02-26T19:09:05.707Z","assignerShortName":"GitHub_M","assignerOrgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateReserved":"2025-01-13T17:15:41.051Z"},"containers":{"cna":{"title":"Potential RCE with a compromised security key in craft/cms","descriptions":[{"lang":"en","value":"Craft is a flexible, user-friendly CMS for creating custom digital experiences on the web and beyond. This is an remote code execution (RCE) vulnerability that affects Craft 4 and 5 installs where your security key has already been compromised. Anyone running an unpatched version of Craft with a compromised security key is affected. This vulnerability has been patched in Craft 5.5.8 and 4.13.8. Users who cannot update to a patched version, should rotate their security keys and ensure their privacy to help migitgate the issue."}],"affected":[{"vendor":"craftcms","product":"cms","versions":[{"version":">= 5.0.0-RC1, < 5.5.5","status":"affected"},{"version":">= 4.0.0-RC1, < 4.13.8","status":"affected"}]}],"references":[{"url":"https://github.com/craftcms/cms/security/advisories/GHSA-x684-96hh-833x","name":"https://github.com/craftcms/cms/security/advisories/GHSA-x684-96hh-833x","tags":["x_refsource_CONFIRM"]},{"url":"https://github.com/craftcms/cms/commit/e59e22b30c9dd39e5e2c7fe02c147bcbd004e603","name":"https://github.com/craftcms/cms/commit/e59e22b30c9dd39e5e2c7fe02c147bcbd004e603","tags":["x_refsource_MISC"]},{"url":"https://craftcms.com/knowledge-base/securing-craft#keep-your-secrets-secret","name":"https://craftcms.com/knowledge-base/securing-craft#keep-your-secrets-secret","tags":["x_refsource_MISC"]}],"metrics":[{"cvssV3_1":{"attackComplexity":"HIGH","attackVector":"NETWORK","availabilityImpact":"HIGH","baseScore":8.1,"baseSeverity":"HIGH","confidentialityImpact":"HIGH","integrityImpact":"HIGH","privilegesRequired":"LOW","scope":"CHANGED","userInteraction":"REQUIRED","vectorString":"CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H","version":"3.1"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-94","lang":"en","description":"CWE-94: Improper Control of Generation of Code ('Code Injection')","type":"CWE"}]}],"providerMetadata":{"shortName":"GitHub_M","orgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateUpdated":"2025-01-18T00:32:54.954Z"},"source":{"advisory":"GHSA-x684-96hh-833x","discovery":"UNKNOWN"}},"adp":[{"title":"CISA ADP Vulnrichment","references":[{"url":"https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2025-23209","tags":["government-resource"]}],"metrics":[{"other":{"type":"ssvc","content":{"id":"CVE-2025-23209","role":"CISA Coordinator","options":[{"Exploitation":"active"},{"Automatable":"no"},{"Technical Impact":"total"}],"version":"2.0.3","timestamp":"2025-02-21T04:56:13.643788Z"}}},{"other":{"type":"kev","content":{"dateAdded":"2025-02-20","reference":"https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2025-23209"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2026-02-26T19:09:05.707Z"},"timeline":[{"time":"2025-02-20T00:00:00.000Z","lang":"en","value":"CVE-2025-23209 added to CISA KEV"}]}]}}}