{"id":"CVE-2025-23201","state":"PUBLISHED","title":"Reflected Cross-site Scripting on error alert in librenms","description":"librenms is a community-based GPL-licensed network monitoring system. Affected versions are subject to Cross-site Scripting (XSS) on the parameters:`/addhost` -> param: community. Librenms versions up to 24.10.1 allow remote attackers to inject malicious scripts. When a user views or interacts with the page displaying the data, the malicious script executes immediately, leading to potential unauthorized actions or data exposure. This issue has been addressed in release version 24.11.0. Users are advised to upgrade. There are no known workarounds for this vulnerability.","publishedAt":"2025-01-16T22:18:51.754Z","updatedAt":"2025-02-12T20:31:24.886Z","severity":{"score":5.4,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N","source":"GitHub_M"},"assigner":"GitHub_M","products":["librenms librenms"],"affected":[{"vendor":"librenms","product":"librenms","versions":[{"version":"< 24.11.0","status":"affected"}]}],"references":["https://github.com/librenms/librenms/security/advisories/GHSA-g84x-g96g-rcjc"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T20:08:39.238Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2025/23xxx/CVE-2025-23201.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2025-23201","state":"PUBLISHED","datePublished":"2025-01-16T22:18:51.754Z","dateUpdated":"2025-02-12T20:31:24.886Z","assignerShortName":"GitHub_M","assignerOrgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateReserved":"2025-01-13T17:15:41.050Z"},"containers":{"cna":{"title":"Reflected Cross-site Scripting on error alert in librenms","descriptions":[{"lang":"en","value":"librenms is a community-based GPL-licensed network monitoring system. Affected versions are subject to Cross-site Scripting (XSS) on the parameters:`/addhost` -> param: community. Librenms versions up to 24.10.1 allow remote attackers to inject malicious scripts. When a user views or interacts with the page displaying the data, the malicious script executes immediately, leading to potential unauthorized actions or data exposure. This issue has been addressed in release version 24.11.0. Users are advised to upgrade. There are no known workarounds for this vulnerability."}],"affected":[{"vendor":"librenms","product":"librenms","versions":[{"version":"< 24.11.0","status":"affected"}]}],"references":[{"url":"https://github.com/librenms/librenms/security/advisories/GHSA-g84x-g96g-rcjc","name":"https://github.com/librenms/librenms/security/advisories/GHSA-g84x-g96g-rcjc","tags":["x_refsource_CONFIRM"]}],"metrics":[{"cvssV3_1":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"NONE","baseScore":5.4,"baseSeverity":"MEDIUM","confidentialityImpact":"LOW","integrityImpact":"LOW","privilegesRequired":"NONE","scope":"UNCHANGED","userInteraction":"REQUIRED","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N","version":"3.1"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","lang":"en","description":"CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","type":"CWE"}]}],"providerMetadata":{"shortName":"GitHub_M","orgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateUpdated":"2025-01-16T22:18:51.754Z"},"source":{"advisory":"GHSA-g84x-g96g-rcjc","discovery":"UNKNOWN"}},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"id":"CVE-2025-23201","role":"CISA Coordinator","options":[{"Exploitation":"poc"},{"Automatable":"no"},{"Technical Impact":"partial"}],"version":"2.0.3","timestamp":"2025-01-17T15:01:52.074959Z"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-02-12T20:31:24.886Z"}}]}}}