{"id":"CVE-2025-2303","state":"PUBLISHED","title":"Block Logic <= 1.0.8 - Authenticated (Contributor+) Remote Code Execution","description":"The Block Logic – Full Gutenberg Block Display Control plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 1.0.8 via the block_logic_check_logic function. This is due to the unsafe evaluation of user-controlled input. This makes it possible for authenticated attackers, with Contributor-level access and above, to execute code on the server.","publishedAt":"2025-03-22T06:41:11.225Z","updatedAt":"2026-04-08T16:50:44.564Z","severity":{"score":8.8,"label":"High","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","source":"Wordfence"},"assigner":"Wordfence","products":["landwire Block Logic – Full Block Display Control"],"affected":[{"vendor":"landwire","product":"Block Logic – Full Block Display Control","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"1.0.8","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/4a76f851-3f4e-4457-a33c-eede51c4b4d1?source=cve","https://plugins.trac.wordpress.org/browser/block-logic/tags/1.0.8/block-logic.php#L127","https://plugins.trac.wordpress.org/changeset/3430763/"],"weaknesses":["CWE-94"],"ingestedAt":"2026-10-29T20:08:55.257Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2025/2xxx/CVE-2025-2303.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2025-2303","state":"PUBLISHED","datePublished":"2025-03-22T06:41:11.225Z","dateUpdated":"2026-04-08T16:50:44.564Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2025-03-14T10:43:11.949Z"},"containers":{"cna":{"title":"Block Logic <= 1.0.8 - Authenticated (Contributor+) Remote Code Execution","descriptions":[{"lang":"en","value":"The Block Logic – Full Gutenberg Block Display Control plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 1.0.8 via the block_logic_check_logic function. This is due to the unsafe evaluation of user-controlled input. This makes it possible for authenticated attackers, with Contributor-level access and above, to execute code on the server."}],"affected":[{"vendor":"landwire","product":"Block Logic – Full Block Display Control","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"1.0.8","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/4a76f851-3f4e-4457-a33c-eede51c4b4d1?source=cve"},{"url":"https://plugins.trac.wordpress.org/browser/block-logic/tags/1.0.8/block-logic.php#L127"},{"url":"https://plugins.trac.wordpress.org/changeset/3430763/"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","baseScore":8.8,"baseSeverity":"HIGH"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-94","lang":"en","description":"CWE-94 Improper Control of Generation of Code ('Code Injection')","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T16:50:44.564Z"},"credits":[{"lang":"en","type":"finder","value":"Oliver Campion"}],"timeline":[{"time":"2025-03-11T00:00:00.000Z","lang":"en","value":"Discovered"},{"time":"2025-03-21T17:53:40.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-04-01T16:25:49.291496Z","id":"CVE-2025-2303","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"total"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-04-01T16:25:59.291Z"}}]}}}