{"id":"CVE-2025-14630","state":"PUBLISHED","title":"AdminQuickbar <= 1.9.3 - Cross-Site Request Forgery to Settings Update","description":"The AdminQuickbar plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.9.3. This is due to missing or incorrect nonce validation on the 'saveSettings' and 'renamePost' AJAX actions. This makes it possible for unauthenticated attackers to modify plugin settings and update post titles via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.","publishedAt":"2026-01-24T08:26:35.023Z","updatedAt":"2026-04-08T17:18:29.705Z","severity":{"score":4.3,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["rtowebsites AdminQuickbar"],"affected":[{"vendor":"rtowebsites","product":"AdminQuickbar","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"1.9.3","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/bb70ad52-b964-4c56-98a2-06be375a79af?source=cve","https://plugins.trac.wordpress.org/browser/adminquickbar/tags/1.9.3/Lib/AdminQuickbar.php#L88","https://plugins.trac.wordpress.org/browser/adminquickbar/tags/1.9.3/Lib/Sidebar.php#L386","https://plugins.trac.wordpress.org/browser/adminquickbar/trunk/Lib/AdminQuickbar.php#L88","https://plugins.trac.wordpress.org/browser/adminquickbar/trunk/Lib/Sidebar.php#L386"],"weaknesses":["CWE-352"],"ingestedAt":"2026-10-29T20:08:31.050Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2025/14xxx/CVE-2025-14630.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2025-14630","state":"PUBLISHED","datePublished":"2026-01-24T08:26:35.023Z","dateUpdated":"2026-04-08T17:18:29.705Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2025-12-12T21:34:10.952Z"},"containers":{"cna":{"title":"AdminQuickbar <= 1.9.3 - Cross-Site Request Forgery to Settings Update","descriptions":[{"lang":"en","value":"The AdminQuickbar plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.9.3. This is due to missing or incorrect nonce validation on the 'saveSettings' and 'renamePost' AJAX actions. This makes it possible for unauthenticated attackers to modify plugin settings and update post titles via a forged request granted they can trick a site administrator into performing an action such as clicking on a link."}],"affected":[{"vendor":"rtowebsites","product":"AdminQuickbar","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"1.9.3","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/bb70ad52-b964-4c56-98a2-06be375a79af?source=cve"},{"url":"https://plugins.trac.wordpress.org/browser/adminquickbar/tags/1.9.3/Lib/AdminQuickbar.php#L88"},{"url":"https://plugins.trac.wordpress.org/browser/adminquickbar/tags/1.9.3/Lib/Sidebar.php#L386"},{"url":"https://plugins.trac.wordpress.org/browser/adminquickbar/trunk/Lib/AdminQuickbar.php#L88"},{"url":"https://plugins.trac.wordpress.org/browser/adminquickbar/trunk/Lib/Sidebar.php#L386"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N","baseScore":4.3,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-352","lang":"en","description":"CWE-352 Cross-Site Request Forgery (CSRF)","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T17:18:29.705Z"},"credits":[{"lang":"en","type":"finder","value":"Lior Yeshayahu"}],"timeline":[{"time":"2026-01-23T19:27:12.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2026-01-26T15:28:58.390834Z","id":"CVE-2025-14630","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2026-01-26T15:44:27.719Z"}}]}}}