{"id":"CVE-2025-14166","state":"PUBLISHED","title":"WPMasterToolKit (WPMTK) <= 2.13.0 - Authenticated (Contributor+) Code Injection","description":"The WPMasterToolKit plugin for WordPress is vulnerable to PHP Code Injection in all versions up to, and including, 2.13.0. This is due to the plugin allowing Author-level users to create and execute arbitrary PHP code through the Code Snippets feature without proper capability checks. This makes it possible for authenticated attackers, with Contributor-level access and above, to execute arbitrary PHP code on the server, leading to remote code execution, privilege escalation, and complete site compromise.","publishedAt":"2025-12-12T03:20:46.466Z","updatedAt":"2026-04-08T16:56:35.965Z","severity":{"score":5.3,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["ludwigyou WPMasterToolKit (WPMTK) – All in one plugin"],"affected":[{"vendor":"ludwigyou","product":"WPMasterToolKit (WPMTK) – All in one plugin","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"2.13.0","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/6049996a-514a-44f7-9878-4aa43598842a?source=cve","https://plugins.trac.wordpress.org/browser/wpmastertoolkit/trunk/admin/modules/core/class-code-snippets.php#L135","https://plugins.trac.wordpress.org/browser/wpmastertoolkit/tags/2.13.0/admin/modules/core/class-code-snippets.php#L135","https://plugins.trac.wordpress.org/browser/wpmastertoolkit/trunk/admin/modules/core/class-code-snippets.php#L628","https://plugins.trac.wordpress.org/browser/wpmastertoolkit/tags/2.13.0/admin/modules/core/class-code-snippets.php#L628","https://plugins.trac.wordpress.org/log/wpmastertoolkit/"],"weaknesses":["CWE-94"],"ingestedAt":"2026-10-29T20:08:31.050Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2025/14xxx/CVE-2025-14166.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2025-14166","state":"PUBLISHED","datePublished":"2025-12-12T03:20:46.466Z","dateUpdated":"2026-04-08T16:56:35.965Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2025-12-05T21:21:47.576Z"},"containers":{"cna":{"title":"WPMasterToolKit (WPMTK) <= 2.13.0 - Authenticated (Contributor+) Code Injection","descriptions":[{"lang":"en","value":"The WPMasterToolKit plugin for WordPress is vulnerable to PHP Code Injection in all versions up to, and including, 2.13.0. This is due to the plugin allowing Author-level users to create and execute arbitrary PHP code through the Code Snippets feature without proper capability checks. This makes it possible for authenticated attackers, with Contributor-level access and above, to execute arbitrary PHP code on the server, leading to remote code execution, privilege escalation, and complete site compromise."}],"affected":[{"vendor":"ludwigyou","product":"WPMasterToolKit (WPMTK) – All in one plugin","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"2.13.0","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/6049996a-514a-44f7-9878-4aa43598842a?source=cve"},{"url":"https://plugins.trac.wordpress.org/browser/wpmastertoolkit/trunk/admin/modules/core/class-code-snippets.php#L135"},{"url":"https://plugins.trac.wordpress.org/browser/wpmastertoolkit/tags/2.13.0/admin/modules/core/class-code-snippets.php#L135"},{"url":"https://plugins.trac.wordpress.org/browser/wpmastertoolkit/trunk/admin/modules/core/class-code-snippets.php#L628"},{"url":"https://plugins.trac.wordpress.org/browser/wpmastertoolkit/tags/2.13.0/admin/modules/core/class-code-snippets.php#L628"},{"url":"https://plugins.trac.wordpress.org/log/wpmastertoolkit/"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N","baseScore":5.3,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-94","lang":"en","description":"CWE-94 Improper Control of Generation of Code ('Code Injection')","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T16:56:35.965Z"},"credits":[{"lang":"en","type":"finder","value":"Athiwat Tiprasaharn"},{"lang":"en","type":"finder","value":"Itthidej Aramsri"},{"lang":"en","type":"finder","value":"Powpy"},{"lang":"en","type":"finder","value":"Waris Damkham"},{"lang":"en","type":"finder","value":"Varakorn Chanthasri"},{"lang":"en","type":"finder","value":"Peerapat Samatathanyakorn"},{"lang":"en","type":"finder","value":"Sopon Tangpathum (SoNaJaa)"}],"timeline":[{"time":"2025-12-11T14:32:15.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-12-15T17:54:30.314072Z","id":"CVE-2025-14166","options":[{"Exploitation":"none"},{"Automatable":"yes"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-12-15T18:15:27.698Z"}}]}}}