{"id":"CVE-2025-14163","state":"PUBLISHED","title":"Premium Addons for Elementor <= 4.11.53 - Cross-Site Request Forgery via 'insert_inner_template'","description":"The Premium Addons for Elementor plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 4.11.53. This is due to missing nonce validation in the 'insert_inner_template' function. This makes it possible for unauthenticated attackers to create arbitrary Elementor templates via a forged request granted they can trick a site administrator or other user with the edit_posts capability into performing an action such as clicking on a link.","publishedAt":"2025-12-23T09:20:01.059Z","updatedAt":"2026-04-08T17:01:45.736Z","severity":{"score":4.3,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["leap13 Premium Addons for Elementor – Powerful Elementor Templates & Widgets"],"affected":[{"vendor":"leap13","product":"Premium Addons for Elementor – Powerful Elementor Templates & Widgets","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"4.11.53","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/77b57f2a-0b46-4b4a-bdca-1c5218d739ce?source=cve","https://plugins.trac.wordpress.org/browser/premium-addons-for-elementor/tags/4.11.53/includes/templates/classes/manager.php#L246","https://plugins.trac.wordpress.org/browser/premium-addons-for-elementor/tags/4.11.53/includes/templates/classes/manager.php#L40","https://plugins.trac.wordpress.org/changeset/3416254/","https://research.cleantalk.org/cve-2025-14163/"],"weaknesses":["CWE-352"],"ingestedAt":"2026-10-29T20:08:31.050Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2025/14xxx/CVE-2025-14163.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2025-14163","state":"PUBLISHED","datePublished":"2025-12-23T09:20:01.059Z","dateUpdated":"2026-04-08T17:01:45.736Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2025-12-05T21:07:02.189Z"},"containers":{"cna":{"title":"Premium Addons for Elementor <= 4.11.53 - Cross-Site Request Forgery via 'insert_inner_template'","descriptions":[{"lang":"en","value":"The Premium Addons for Elementor plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 4.11.53. This is due to missing nonce validation in the 'insert_inner_template' function. This makes it possible for unauthenticated attackers to create arbitrary Elementor templates via a forged request granted they can trick a site administrator or other user with the edit_posts capability into performing an action such as clicking on a link."}],"affected":[{"vendor":"leap13","product":"Premium Addons for Elementor – Powerful Elementor Templates & Widgets","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"4.11.53","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/77b57f2a-0b46-4b4a-bdca-1c5218d739ce?source=cve"},{"url":"https://plugins.trac.wordpress.org/browser/premium-addons-for-elementor/tags/4.11.53/includes/templates/classes/manager.php#L246"},{"url":"https://plugins.trac.wordpress.org/browser/premium-addons-for-elementor/tags/4.11.53/includes/templates/classes/manager.php#L40"},{"url":"https://plugins.trac.wordpress.org/changeset/3416254/"},{"url":"https://research.cleantalk.org/cve-2025-14163/"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N","baseScore":4.3,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-352","lang":"en","description":"CWE-352 Cross-Site Request Forgery (CSRF)","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T17:01:45.736Z"},"credits":[{"lang":"en","type":"finder","value":"Dmitrii Ignatyev"}],"timeline":[{"time":"2025-12-22T00:00:00.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-12-23T15:26:58.110622Z","id":"CVE-2025-14163","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-12-23T15:27:05.274Z"}}]}}}