{"id":"CVE-2025-14161","state":"PUBLISHED","title":"Truefy Embed <= 1.1.0 - Cross-Site Request Forgery to 'truefy_embed_options_update' Settings Update","description":"The Truefy Embed plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.1.0. This is due to missing nonce validation on the 'truefy_embed_options_update' settings update action. This makes it possible for unauthenticated attackers to update the plugin's settings, including the API key, via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.","publishedAt":"2025-12-12T03:20:49.231Z","updatedAt":"2026-04-08T17:01:12.525Z","severity":{"score":4.3,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["truefy Truefy Embed"],"affected":[{"vendor":"truefy","product":"Truefy Embed","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"1.1.0","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/74ad664d-5cfa-481c-a318-30999c43e4ac?source=cve","https://plugins.trac.wordpress.org/browser/truefy-embed/trunk/truefy.php#L431","https://plugins.trac.wordpress.org/browser/truefy-embed/tags/1.1.0/truefy.php#L431"],"weaknesses":["CWE-352"],"ingestedAt":"2026-10-29T20:08:31.050Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2025/14xxx/CVE-2025-14161.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2025-14161","state":"PUBLISHED","datePublished":"2025-12-12T03:20:49.231Z","dateUpdated":"2026-04-08T17:01:12.525Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2025-12-05T20:43:20.316Z"},"containers":{"cna":{"title":"Truefy Embed <= 1.1.0 - Cross-Site Request Forgery to 'truefy_embed_options_update' Settings Update","descriptions":[{"lang":"en","value":"The Truefy Embed plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.1.0. This is due to missing nonce validation on the 'truefy_embed_options_update' settings update action. This makes it possible for unauthenticated attackers to update the plugin's settings, including the API key, via a forged request granted they can trick a site administrator into performing an action such as clicking on a link."}],"affected":[{"vendor":"truefy","product":"Truefy Embed","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"1.1.0","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/74ad664d-5cfa-481c-a318-30999c43e4ac?source=cve"},{"url":"https://plugins.trac.wordpress.org/browser/truefy-embed/trunk/truefy.php#L431"},{"url":"https://plugins.trac.wordpress.org/browser/truefy-embed/tags/1.1.0/truefy.php#L431"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N","baseScore":4.3,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-352","lang":"en","description":"CWE-352 Cross-Site Request Forgery (CSRF)","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T17:01:12.525Z"},"credits":[{"lang":"en","type":"finder","value":"dayea song"}],"timeline":[{"time":"2025-12-11T14:37:17.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-12-12T20:23:20.242389Z","id":"CVE-2025-14161","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-12-15T18:14:25.133Z"}}]}}}