{"id":"CVE-2025-13904","state":"PUBLISHED","title":"WPGancio <= 1.12 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode Attributes","description":"The WPGancio plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'gancio-event' shortcode in all versions up to, and including, 1.12 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.","publishedAt":"2025-12-12T03:20:45.215Z","updatedAt":"2026-04-08T16:54:45.057Z","severity":{"score":6.4,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["lesion WPGancio"],"affected":[{"vendor":"lesion","product":"WPGancio","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"1.12","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/593fefe1-8813-440b-b8c7-fbfd5b71a737?source=cve","https://plugins.trac.wordpress.org/browser/wpgancio/trunk/wc.php#L33","https://plugins.trac.wordpress.org/browser/wpgancio/tags/1.12/wc.php#L33"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T20:08:31.050Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2025/13xxx/CVE-2025-13904.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2025-13904","state":"PUBLISHED","datePublished":"2025-12-12T03:20:45.215Z","dateUpdated":"2026-04-08T16:54:45.057Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2025-12-02T16:35:13.635Z"},"containers":{"cna":{"title":"WPGancio <= 1.12 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode Attributes","descriptions":[{"lang":"en","value":"The WPGancio plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'gancio-event' shortcode in all versions up to, and including, 1.12 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page."}],"affected":[{"vendor":"lesion","product":"WPGancio","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"1.12","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/593fefe1-8813-440b-b8c7-fbfd5b71a737?source=cve"},{"url":"https://plugins.trac.wordpress.org/browser/wpgancio/trunk/wc.php#L33"},{"url":"https://plugins.trac.wordpress.org/browser/wpgancio/tags/1.12/wc.php#L33"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","baseScore":6.4,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","lang":"en","description":"CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T16:54:45.057Z"},"credits":[{"lang":"en","type":"finder","value":"Gilang Asra Bilhadi"}],"timeline":[{"time":"2025-12-11T14:37:35.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-12-15T18:05:32.698741Z","id":"CVE-2025-13904","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-12-15T18:15:46.109Z"}}]}}}