{"id":"CVE-2025-13629","state":"PUBLISHED","title":"WP Landing Page <= 0.9.3 - Cross-Site Request Forgery to Arbitrary Post Meta Update","description":"The WP Landing Page plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 0.9.3. This is due to missing nonce validation on the 'wplp_api_update_text' function. This makes it possible for unauthenticated attackers to update arbitrary post meta via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.","publishedAt":"2025-12-06T05:49:26.481Z","updatedAt":"2026-04-08T16:49:14.832Z","severity":{"score":4.3,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["xbenx WP Landing Page"],"affected":[{"vendor":"xbenx","product":"WP Landing Page","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"0.9.3","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/43d8576b-e6ad-4e0a-b99f-948ba36f53ff?source=cve","https://plugins.trac.wordpress.org/browser/wp-landing-page/trunk/includes/wplp-api.php#L14","https://plugins.trac.wordpress.org/browser/wp-landing-page/tags/0.9.3/includes/wplp-api.php#L14"],"weaknesses":["CWE-352"],"ingestedAt":"2026-10-29T20:08:31.050Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2025/13xxx/CVE-2025-13629.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2025-13629","state":"PUBLISHED","datePublished":"2025-12-06T05:49:26.481Z","dateUpdated":"2026-04-08T16:49:14.832Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2025-11-24T21:40:10.616Z"},"containers":{"cna":{"title":"WP Landing Page <= 0.9.3 - Cross-Site Request Forgery to Arbitrary Post Meta Update","descriptions":[{"lang":"en","value":"The WP Landing Page plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 0.9.3. This is due to missing nonce validation on the 'wplp_api_update_text' function. This makes it possible for unauthenticated attackers to update arbitrary post meta via a forged request granted they can trick a site administrator into performing an action such as clicking on a link."}],"affected":[{"vendor":"xbenx","product":"WP Landing Page","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"0.9.3","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/43d8576b-e6ad-4e0a-b99f-948ba36f53ff?source=cve"},{"url":"https://plugins.trac.wordpress.org/browser/wp-landing-page/trunk/includes/wplp-api.php#L14"},{"url":"https://plugins.trac.wordpress.org/browser/wp-landing-page/tags/0.9.3/includes/wplp-api.php#L14"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N","baseScore":4.3,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-352","lang":"en","description":"CWE-352 Cross-Site Request Forgery (CSRF)","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T16:49:14.832Z"},"credits":[{"lang":"en","type":"finder","value":"Ivan Cese"}],"timeline":[{"time":"2025-12-05T17:38:17.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-12-08T21:11:33.660023Z","id":"CVE-2025-13629","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-12-08T21:11:43.968Z"}}]}}}