{"id":"CVE-2025-13592","state":"PUBLISHED","title":"Advanced Ads <= 2.0.14 - Authenticated (Editor+) Remote Code Execution via Shortcode","description":"The Advanced Ads plugin for WordPress is vulnerable to Remote Code Execution in versions up to, and including, 2.0.14 via the 'change-ad__content' shortcode parameter. This allows authenticated attackers with editor-level permissions or above, to execute code on the server.","publishedAt":"2025-12-29T18:20:50.576Z","updatedAt":"2026-04-08T17:34:16.769Z","severity":{"score":7.2,"label":"High","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H","source":"Wordfence"},"assigner":"Wordfence","products":["monetizemore Advanced Ads – Ad Manager & AdSense"],"affected":[{"vendor":"monetizemore","product":"Advanced Ads – Ad Manager & AdSense","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"2.0.14","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/f9e83561-aa71-4984-8a26-207e208d70e8?source=cve","https://plugins.trac.wordpress.org/browser/advanced-ads/tags/2.0.14/includes/ads/class-ad-plain.php#L36","https://plugins.trac.wordpress.org/changeset/3427297/advanced-ads#file9"],"weaknesses":["CWE-94"],"ingestedAt":"2026-10-29T20:08:31.050Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2025/13xxx/CVE-2025-13592.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2025-13592","state":"PUBLISHED","datePublished":"2025-12-29T18:20:50.576Z","dateUpdated":"2026-04-08T17:34:16.769Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2025-11-24T06:36:17.899Z"},"containers":{"cna":{"title":"Advanced Ads <= 2.0.14 - Authenticated (Editor+) Remote Code Execution via Shortcode","descriptions":[{"lang":"en","value":"The Advanced Ads plugin for WordPress is vulnerable to Remote Code Execution in versions up to, and including, 2.0.14 via the 'change-ad__content' shortcode parameter. This allows authenticated attackers with editor-level permissions or above, to execute code on the server."}],"affected":[{"vendor":"monetizemore","product":"Advanced Ads – Ad Manager & AdSense","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"2.0.14","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/f9e83561-aa71-4984-8a26-207e208d70e8?source=cve"},{"url":"https://plugins.trac.wordpress.org/browser/advanced-ads/tags/2.0.14/includes/ads/class-ad-plain.php#L36"},{"url":"https://plugins.trac.wordpress.org/changeset/3427297/advanced-ads#file9"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H","baseScore":7.2,"baseSeverity":"HIGH"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-94","lang":"en","description":"CWE-94 Improper Control of Generation of Code ('Code Injection')","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T17:34:16.769Z"},"credits":[{"lang":"en","type":"finder","value":"NosleeP"}],"timeline":[{"time":"2025-12-29T06:04:25.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-12-30T21:57:13.459911Z","id":"CVE-2025-13592","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"total"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-12-30T22:30:07.259Z"}}]}}}