{"id":"CVE-2025-1319","state":"PUBLISHED","title":"Site Mailer <= 1.2.3 - Unauthenticated Stored Cross-Site Scripting","description":"The Site Mailer – SMTP Replacement, Email API Deliverability & Email Log plugin for WordPress is vulnerable to Stored Cross-Site Scripting in all versions up to, and including, 1.2.3 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.","publishedAt":"2025-02-28T12:44:05.371Z","updatedAt":"2026-04-08T17:22:01.081Z","severity":{"score":7.2,"label":"High","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["elemntor Site Mailer – SMTP Replacement, Email API Deliverability & Email Log"],"affected":[{"vendor":"elemntor","product":"Site Mailer – SMTP Replacement, Email API Deliverability & Email Log","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"1.2.3","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/c9fe3574-f338-474c-af78-f843501d422c?source=cve","https://wordpress.org/plugins/site-mailer/#developers","https://plugins.trac.wordpress.org/changeset/3247059/"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T20:08:39.238Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2025/1xxx/CVE-2025-1319.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2025-1319","state":"PUBLISHED","datePublished":"2025-02-28T12:44:05.371Z","dateUpdated":"2026-04-08T17:22:01.081Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2025-02-14T22:48:31.797Z"},"containers":{"cna":{"title":"Site Mailer <= 1.2.3 - Unauthenticated Stored Cross-Site Scripting","descriptions":[{"lang":"en","value":"The Site Mailer – SMTP Replacement, Email API Deliverability & Email Log plugin for WordPress is vulnerable to Stored Cross-Site Scripting in all versions up to, and including, 1.2.3 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page."}],"affected":[{"vendor":"elemntor","product":"Site Mailer – SMTP Replacement, Email API Deliverability & Email Log","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"1.2.3","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/c9fe3574-f338-474c-af78-f843501d422c?source=cve"},{"url":"https://wordpress.org/plugins/site-mailer/#developers"},{"url":"https://plugins.trac.wordpress.org/changeset/3247059/"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N","baseScore":7.2,"baseSeverity":"HIGH"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","lang":"en","description":"CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T17:22:01.081Z"},"credits":[{"lang":"en","type":"finder","value":"D.Sim"}],"timeline":[{"time":"2025-02-27T23:34:36.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-02-28T13:00:33.129800Z","id":"CVE-2025-1319","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-02-28T13:00:41.576Z"}}]}}}