{"id":"CVE-2025-12681","state":"PUBLISHED","title":"Comment Edit Core – Simple Comment Editing <= 3.1.0 - Unauthenticated Sensitive Information Exposure","description":"The Comment Edit Core – Simple Comment Editing plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 3.1.0 via the 'ajax_get_comment' function. This makes it possible for unauthenticated attackers to extract sensitive data including user IDs, IP addresses, and email addresses.","publishedAt":"2025-11-13T07:27:53.227Z","updatedAt":"2026-04-08T16:52:06.099Z","severity":{"score":5.3,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["ronalfy Comment Edit Core – Simple Comment Editing"],"affected":[{"vendor":"ronalfy","product":"Comment Edit Core – Simple Comment Editing","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"3.1.0","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/4f954b02-b636-438b-a4b1-9b74df153c47?source=cve","https://plugins.trac.wordpress.org/browser/simple-comment-editing/trunk/includes/Ajax.php#L230","https://plugins.trac.wordpress.org/changeset/3392054/"],"weaknesses":["CWE-200"],"ingestedAt":"2026-10-29T20:08:31.050Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2025/12xxx/CVE-2025-12681.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2025-12681","state":"PUBLISHED","datePublished":"2025-11-13T07:27:53.227Z","dateUpdated":"2026-04-08T16:52:06.099Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2025-11-04T00:25:24.942Z"},"containers":{"cna":{"title":"Comment Edit Core – Simple Comment Editing <= 3.1.0 - Unauthenticated Sensitive Information Exposure","descriptions":[{"lang":"en","value":"The Comment Edit Core – Simple Comment Editing plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 3.1.0 via the 'ajax_get_comment' function. This makes it possible for unauthenticated attackers to extract sensitive data including user IDs, IP addresses, and email addresses."}],"affected":[{"vendor":"ronalfy","product":"Comment Edit Core – Simple Comment Editing","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"3.1.0","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/4f954b02-b636-438b-a4b1-9b74df153c47?source=cve"},{"url":"https://plugins.trac.wordpress.org/browser/simple-comment-editing/trunk/includes/Ajax.php#L230"},{"url":"https://plugins.trac.wordpress.org/changeset/3392054/"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N","baseScore":5.3,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-200","lang":"en","description":"CWE-200 Exposure of Sensitive Information to an Unauthorized Actor","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T16:52:06.099Z"},"credits":[{"lang":"en","type":"finder","value":"Powpy"}],"timeline":[{"time":"2025-11-07T20:28:27.000Z","lang":"en","value":"Vendor Notified"},{"time":"2025-11-12T00:00:00.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-11-14T16:48:30.539607Z","id":"CVE-2025-12681","options":[{"Exploitation":"none"},{"Automatable":"yes"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-11-14T16:48:37.608Z"}}]}}}