{"id":"CVE-2025-12389","state":"PUBLISHED","title":"Import Export For WooCommerce <= 1.6.2 - Missing Authorization to Authenticated (Subscriber+) Settings Update","description":"The Import Export For WooCommerce plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the update_setting() function in all versions up to, and including, 1.6.2. This makes it possible for authenticated attackers, with Subscriber-level access and above, to update the plugin's record setting.","publishedAt":"2025-11-04T04:27:21.061Z","updatedAt":"2026-04-08T17:13:19.058Z","severity":{"score":4.3,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["sidngr Import Export For WooCommerce"],"affected":[{"vendor":"sidngr","product":"Import Export For WooCommerce","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"1.6.2","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/a5a93e3f-54c6-4970-96fd-fab0e81f7034?source=cve","https://wordpress.org/plugins/import-export-for-woocommerce/"],"weaknesses":["CWE-862"],"ingestedAt":"2026-10-29T20:08:31.050Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2025/12xxx/CVE-2025-12389.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2025-12389","state":"PUBLISHED","datePublished":"2025-11-04T04:27:21.061Z","dateUpdated":"2026-04-08T17:13:19.058Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2025-10-28T13:13:22.814Z"},"containers":{"cna":{"title":"Import Export For WooCommerce <= 1.6.2 - Missing Authorization to Authenticated (Subscriber+) Settings Update","descriptions":[{"lang":"en","value":"The Import Export For WooCommerce plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the update_setting() function in all versions up to, and including, 1.6.2. This makes it possible for authenticated attackers, with Subscriber-level access and above, to update the plugin's record setting."}],"affected":[{"vendor":"sidngr","product":"Import Export For WooCommerce","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"1.6.2","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/a5a93e3f-54c6-4970-96fd-fab0e81f7034?source=cve"},{"url":"https://wordpress.org/plugins/import-export-for-woocommerce/"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N","baseScore":4.3,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-862","lang":"en","description":"CWE-862 Missing Authorization","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T17:13:19.058Z"},"credits":[{"lang":"en","type":"finder","value":"Abhirup Konwar"}],"timeline":[{"time":"2025-11-03T16:00:23.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-11-04T15:20:14.650253Z","id":"CVE-2025-12389","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-11-04T15:20:23.287Z"}}]}}}