{"id":"CVE-2025-12034","state":"PUBLISHED","title":"Fast Velocity Minify <= 3.5.1 - Authenticated (Admin+) Stored Cross-Site Scripting","description":"The Fast Velocity Minify plugin for WordPress is vulnerable to Stored Cross-Site Scripting via admin settings in all versions up to, and including, 3.5.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.","publishedAt":"2025-10-25T06:49:20.557Z","updatedAt":"2026-04-08T16:38:23.899Z","severity":{"score":4.4,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:L/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["alignak Fast Velocity Minify"],"affected":[{"vendor":"alignak","product":"Fast Velocity Minify","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"3.5.1","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/1c02e03a-7f96-4efa-9071-4a76fb21900d?source=cve","https://github.com/peixotorms/fast-velocity-minify/commit/55a8b53a2ec6d358f8d7ad181170b9d8112e78ab","https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3383015%40fast-velocity-minify&new=3383015%40fast-velocity-minify&sfp_email=&sfph_mail="],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T20:08:31.050Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2025/12xxx/CVE-2025-12034.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2025-12034","state":"PUBLISHED","datePublished":"2025-10-25T06:49:20.557Z","dateUpdated":"2026-04-08T16:38:23.899Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2025-10-21T17:36:37.692Z"},"containers":{"cna":{"title":"Fast Velocity Minify <= 3.5.1 - Authenticated (Admin+) Stored Cross-Site Scripting","descriptions":[{"lang":"en","value":"The Fast Velocity Minify plugin for WordPress is vulnerable to Stored Cross-Site Scripting via admin settings in all versions up to, and including, 3.5.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled."}],"affected":[{"vendor":"alignak","product":"Fast Velocity Minify","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"3.5.1","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/1c02e03a-7f96-4efa-9071-4a76fb21900d?source=cve"},{"url":"https://github.com/peixotorms/fast-velocity-minify/commit/55a8b53a2ec6d358f8d7ad181170b9d8112e78ab"},{"url":"https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3383015%40fast-velocity-minify&new=3383015%40fast-velocity-minify&sfp_email=&sfph_mail="}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:L/I:L/A:N","baseScore":4.4,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","lang":"en","description":"CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T16:38:23.899Z"},"credits":[{"lang":"en","type":"finder","value":"Cody Sixteen"}],"timeline":[{"time":"2025-10-23T01:50:51.000Z","lang":"en","value":"Vendor Notified"},{"time":"2025-10-24T18:28:09.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-10-27T15:54:38.955807Z","id":"CVE-2025-12034","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-10-27T15:54:50.525Z"}}]}}}