{"id":"CVE-2025-11926","state":"PUBLISHED","title":"Related Posts Lite <= 1.12 - Authenticated (Admin+) Stored Cross-Site Scripting","description":"The Related Posts Lite plugin for WordPress is vulnerable to Stored Cross-Site Scripting via admin settings in all versions up to, and including, 1.12 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.","publishedAt":"2025-10-18T09:25:31.949Z","updatedAt":"2026-04-08T16:55:57.992Z","severity":{"score":4.4,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:L/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["wpdreams Related Posts Lite"],"affected":[{"vendor":"wpdreams","product":"Related Posts Lite","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"1.12","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/5dadd49c-33b2-43d8-a6a9-64a3c37c4b52?source=cve","https://plugins.trac.wordpress.org/browser/related-posts-lite/tags/1.12/","https://wordpress.org/plugins/related-posts-lite/?utm_source=chatgpt.com","https://github.com/prabhatverma47/Wordpress-Related-Posts-Lite-plugin-XSS-PoC?utm_source=chatgpt.com"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T20:08:31.050Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2025/11xxx/CVE-2025-11926.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2025-11926","state":"PUBLISHED","datePublished":"2025-10-18T09:25:31.949Z","dateUpdated":"2026-04-08T16:55:57.992Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2025-10-17T20:29:26.584Z"},"containers":{"cna":{"title":"Related Posts Lite <= 1.12 - Authenticated (Admin+) Stored Cross-Site Scripting","descriptions":[{"lang":"en","value":"The Related Posts Lite plugin for WordPress is vulnerable to Stored Cross-Site Scripting via admin settings in all versions up to, and including, 1.12 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled."}],"affected":[{"vendor":"wpdreams","product":"Related Posts Lite","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"1.12","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/5dadd49c-33b2-43d8-a6a9-64a3c37c4b52?source=cve"},{"url":"https://plugins.trac.wordpress.org/browser/related-posts-lite/tags/1.12/"},{"url":"https://wordpress.org/plugins/related-posts-lite/?utm_source=chatgpt.com"},{"url":"https://github.com/prabhatverma47/Wordpress-Related-Posts-Lite-plugin-XSS-PoC?utm_source=chatgpt.com"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:L/I:L/A:N","baseScore":4.4,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","lang":"en","description":"CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T16:55:57.992Z"},"credits":[{"lang":"en","type":"finder","value":"Prabhat Verma"}],"timeline":[{"time":"2025-10-17T20:44:34.000Z","lang":"en","value":"Vendor Notified"},{"time":"2025-10-17T00:00:00.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-10-20T16:54:53.012412Z","id":"CVE-2025-11926","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-10-20T16:55:27.944Z"}}]}}}