{"id":"CVE-2025-11729","state":"PUBLISHED","title":"PPWP: Password Protect Pages, Posts & Full or Partial Content <= 1.9.15 - Improper Authorization To Authenticated (Contributor+) Master Password Exposure","description":"The PPWP: Password Protect Pages, Posts & Full or Partial Content plugin for WordPress is vulnerable to unauthorized access of data due to a improper capability check on the can_access function in all versions up to, and including, 1.9.15. This makes it possible for authenticated attackers, with Contributor-level access and above, to retrieve a master-password and access any password-protected content.","publishedAt":"2026-08-18T23:25:59.669Z","updatedAt":"2026-08-19T15:50:02.251Z","severity":{"score":4.3,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["buildwps PPWP – Password Protect Pages"],"affected":[{"vendor":"buildwps","product":"PPWP – Password Protect Pages","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"1.9.15","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/d1e041f0-3019-4d1f-b1a3-b40275c0966a?source=cve","https://plugins.trac.wordpress.org/changeset/3486400/"],"weaknesses":["CWE-285"],"ingestedAt":"2026-10-29T20:08:31.050Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2025/11xxx/CVE-2025-11729.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2025-11729","state":"PUBLISHED","datePublished":"2026-08-18T23:25:59.669Z","dateUpdated":"2026-08-19T15:50:02.251Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2025-10-13T23:20:05.919Z"},"containers":{"cna":{"title":"PPWP: Password Protect Pages, Posts & Full or Partial Content <= 1.9.15 - Improper Authorization To Authenticated (Contributor+) Master Password Exposure","descriptions":[{"lang":"en","value":"The PPWP: Password Protect Pages, Posts & Full or Partial Content plugin for WordPress is vulnerable to unauthorized access of data due to a improper capability check on the can_access function in all versions up to, and including, 1.9.15. This makes it possible for authenticated attackers, with Contributor-level access and above, to retrieve a master-password and access any password-protected content."}],"affected":[{"vendor":"buildwps","product":"PPWP – Password Protect Pages","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"1.9.15","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/d1e041f0-3019-4d1f-b1a3-b40275c0966a?source=cve"},{"url":"https://plugins.trac.wordpress.org/changeset/3486400/"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N","baseScore":4.3,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-285","lang":"en","description":"CWE-285 Improper Authorization","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-08-18T23:25:59.669Z"},"credits":[{"lang":"en","type":"finder","value":"Athiwat Tiprasaharn (Jitlada)"}],"timeline":[{"time":"2025-10-04T00:00:00.000Z","lang":"en","value":"Discovered"},{"time":"2025-10-13T23:35:41.000Z","lang":"en","value":"Vendor Notified"},{"time":"2026-08-18T11:03:47.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2026-08-19T15:49:37.437231Z","id":"CVE-2025-11729","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2026-08-19T15:50:02.251Z"}}]}}}