{"id":"CVE-2025-11220","state":"PUBLISHED","title":"Elementor <= 3.33.3  - Authenticated (Contributor+) Stored DOM-Based Cross-Site Scripting via Text Path","description":"The Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's Text Path widget in all versions up to, and including, 3.33.3  due to insufficient neutralization of user-supplied input used to build SVG markup inside the widget. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.","publishedAt":"2025-12-16T11:15:44.155Z","updatedAt":"2026-04-08T16:38:05.769Z","severity":{"score":6.4,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["elemntor Elementor Website Builder – more than just a page builder"],"affected":[{"vendor":"elemntor","product":"Elementor Website Builder – more than just a page builder","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"3.33.3","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/1a73c078-ce66-4131-8bd7-6fd48fc9fa84?source=cve","https://plugins.trac.wordpress.org/changeset/3414494/elementor"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T20:08:31.050Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2025/11xxx/CVE-2025-11220.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2025-11220","state":"PUBLISHED","datePublished":"2025-12-16T11:15:44.155Z","dateUpdated":"2026-04-08T16:38:05.769Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2025-09-30T23:12:28.298Z"},"containers":{"cna":{"title":"Elementor <= 3.33.3  - Authenticated (Contributor+) Stored DOM-Based Cross-Site Scripting via Text Path","descriptions":[{"lang":"en","value":"The Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's Text Path widget in all versions up to, and including, 3.33.3  due to insufficient neutralization of user-supplied input used to build SVG markup inside the widget. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page."}],"affected":[{"vendor":"elemntor","product":"Elementor Website Builder – more than just a page builder","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"3.33.3","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/1a73c078-ce66-4131-8bd7-6fd48fc9fa84?source=cve"},{"url":"https://plugins.trac.wordpress.org/changeset/3414494/elementor"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","baseScore":6.4,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","lang":"en","description":"CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T16:38:05.769Z"},"credits":[{"lang":"en","type":"finder","value":"Asaf Mozes"}],"timeline":[{"time":"2025-09-30T23:29:19.000Z","lang":"en","value":"Vendor Notified"},{"time":"2025-12-15T22:04:49.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-12-16T14:49:40.804046Z","id":"CVE-2025-11220","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-12-16T14:49:52.645Z"}}]}}}