{"id":"CVE-2025-10938","state":"PUBLISHED","title":"UiPress lite <= 3.5.09 - Missing Authorization to Authenticated (Subscriber+) Sensitive Information Exposure","description":"The UiPress lite plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 3.5.08. This is due to missing capability checks in the 'uip_process_block_query' AJAX function. This makes it possible for authenticated attackers, with subscriber-level access and above, to extract sensitive user data including password hashes, emails, and other user information that could be used for account takeover attacks.","publishedAt":"2025-11-21T07:31:55.890Z","updatedAt":"2026-09-14T19:51:59.728Z","severity":{"score":6.5,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["admintwentytwenty UiPress lite | Effortless custom dashboards, admin themes and pages"],"affected":[{"vendor":"admintwentytwenty","product":"UiPress lite | Effortless custom dashboards, admin themes and pages","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"3.5.09","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/d8aa06eb-774a-4cd9-bd35-2d6409475696?source=cve","https://plugins.trac.wordpress.org/changeset/3654103/"],"weaknesses":["CWE-862"],"ingestedAt":"2026-10-29T20:08:20.985Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2025/10xxx/CVE-2025-10938.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2025-10938","state":"PUBLISHED","datePublished":"2025-11-21T07:31:55.890Z","dateUpdated":"2026-09-14T19:51:59.728Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2025-09-25T00:03:45.616Z"},"containers":{"cna":{"title":"UiPress lite <= 3.5.09 - Missing Authorization to Authenticated (Subscriber+) Sensitive Information Exposure","descriptions":[{"lang":"en","value":"The UiPress lite plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 3.5.08. This is due to missing capability checks in the 'uip_process_block_query' AJAX function. This makes it possible for authenticated attackers, with subscriber-level access and above, to extract sensitive user data including password hashes, emails, and other user information that could be used for account takeover attacks."}],"affected":[{"vendor":"admintwentytwenty","product":"UiPress lite | Effortless custom dashboards, admin themes and pages","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"3.5.09","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/d8aa06eb-774a-4cd9-bd35-2d6409475696?source=cve"},{"url":"https://plugins.trac.wordpress.org/changeset/3654103/"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","baseScore":6.5,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-862","lang":"en","description":"CWE-862 Missing Authorization","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-09-14T19:51:59.728Z"},"credits":[{"lang":"en","type":"finder","value":"abrahack"}],"timeline":[{"time":"2025-11-20T19:18:39.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-11-21T14:48:01.742437Z","id":"CVE-2025-10938","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-11-21T14:56:39.398Z"}}]}}}