{"id":"CVE-2025-10580","state":"PUBLISHED","title":"Widget Options – The #1 WordPress Widget & Block Control Plugin <= 4.1.2 - Authenticated (Contributor+) Stored Cross-Site Scripting","description":"The Widget Options – The #1 WordPress Widget & Block Control Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via multiple functions in all versions up to, and including, 4.1.2 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.","publishedAt":"2025-10-25T06:49:22.861Z","updatedAt":"2026-04-08T17:03:44.738Z","severity":{"score":6.4,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["marketingfire Widget Options – Advanced Conditional Visibility for Gutenberg Blocks & Classic Widgets"],"affected":[{"vendor":"marketingfire","product":"Widget Options – Advanced Conditional Visibility for Gutenberg Blocks & Classic Widgets","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"4.1.2","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/8169e533-ef3b-4fd7-9571-61e5528b7652?source=cve","https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3382357%40widget-options&new=3382357%40widget-options&sfp_email=&sfph_mail="],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T20:08:20.985Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2025/10xxx/CVE-2025-10580.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2025-10580","state":"PUBLISHED","datePublished":"2025-10-25T06:49:22.861Z","dateUpdated":"2026-04-08T17:03:44.738Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2025-09-16T19:56:41.305Z"},"containers":{"cna":{"title":"Widget Options – The #1 WordPress Widget & Block Control Plugin <= 4.1.2 - Authenticated (Contributor+) Stored Cross-Site Scripting","descriptions":[{"lang":"en","value":"The Widget Options – The #1 WordPress Widget & Block Control Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via multiple functions in all versions up to, and including, 4.1.2 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page."}],"affected":[{"vendor":"marketingfire","product":"Widget Options – Advanced Conditional Visibility for Gutenberg Blocks & Classic Widgets","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"4.1.2","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/8169e533-ef3b-4fd7-9571-61e5528b7652?source=cve"},{"url":"https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3382357%40widget-options&new=3382357%40widget-options&sfp_email=&sfph_mail="}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","baseScore":6.4,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","lang":"en","description":"CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T17:03:44.738Z"},"credits":[{"lang":"en","type":"finder","value":"Nguyen Ngoc Quang Bach"}],"timeline":[{"time":"2025-09-16T20:11:58.000Z","lang":"en","value":"Vendor Notified"},{"time":"2025-10-24T00:00:00.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-10-27T15:45:12.849294Z","id":"CVE-2025-10580","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-10-27T15:45:22.899Z"}}]}}}