{"id":"CVE-2025-10165","state":"PUBLISHED","title":"AP Background <= 3.8.2 - Authenticated (Contributor+) Stored Cross-Site Scripting","description":"The AP Background plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'adv_parallax_back' shortcode in all versions up to, and including, 3.8.2 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.","publishedAt":"2025-10-03T11:17:23.636Z","updatedAt":"2026-04-08T17:34:11.812Z","severity":{"score":6.4,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["hovanesvn AP Background"],"affected":[{"vendor":"hovanesvn","product":"AP Background","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"3.8.2","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/f98b848c-9f97-4d00-97de-7651b9035731?source=cve","https://plugins.trac.wordpress.org/browser/ap-background/trunk/includes/shortCodeClass.php#L44","https://wordpress.org/plugins/ap-background"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T20:08:20.985Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2025/10xxx/CVE-2025-10165.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2025-10165","state":"PUBLISHED","datePublished":"2025-10-03T11:17:23.636Z","dateUpdated":"2026-04-08T17:34:11.812Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2025-09-09T13:28:12.112Z"},"containers":{"cna":{"title":"AP Background <= 3.8.2 - Authenticated (Contributor+) Stored Cross-Site Scripting","descriptions":[{"lang":"en","value":"The AP Background plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'adv_parallax_back' shortcode in all versions up to, and including, 3.8.2 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page."}],"affected":[{"vendor":"hovanesvn","product":"AP Background","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"3.8.2","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/f98b848c-9f97-4d00-97de-7651b9035731?source=cve"},{"url":"https://plugins.trac.wordpress.org/browser/ap-background/trunk/includes/shortCodeClass.php#L44"},{"url":"https://wordpress.org/plugins/ap-background"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","baseScore":6.4,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","lang":"en","description":"CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T17:34:11.812Z"},"credits":[{"lang":"en","type":"finder","value":"Djaidja Moundjid"}],"timeline":[{"time":"2025-10-02T21:28:49.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-10-03T13:57:13.845664Z","id":"CVE-2025-10165","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-10-03T13:57:27.086Z"}}]}}}