{"id":"CVE-2025-10139","state":"PUBLISHED","title":"WP BookWidgets <= 0.9 - Authenticated (Contributor+) Stored Cross-Site Scripting","description":"The WP BookWidgets plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'bw_link' shortcode in all versions up to, and including, 0.9 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.","publishedAt":"2025-10-15T08:25:49.749Z","updatedAt":"2026-04-08T16:37:17.825Z","severity":{"score":6.4,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["remko WP BookWidgets"],"affected":[{"vendor":"remko","product":"WP BookWidgets","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"0.9","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/1716743f-8259-40fb-bc9b-53e3dfef8816?source=cve","https://plugins.trac.wordpress.org/browser/wp-bookwidgets/trunk/wp-bookwidgets.php#L163","https://wordpress.org/plugins/wp-bookwidgets","https://plugins.trac.wordpress.org/changeset/3380322/"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T20:08:20.985Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2025/10xxx/CVE-2025-10139.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2025-10139","state":"PUBLISHED","datePublished":"2025-10-15T08:25:49.749Z","dateUpdated":"2026-04-08T16:37:17.825Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2025-09-08T20:31:24.382Z"},"containers":{"cna":{"title":"WP BookWidgets <= 0.9 - Authenticated (Contributor+) Stored Cross-Site Scripting","descriptions":[{"lang":"en","value":"The WP BookWidgets plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'bw_link' shortcode in all versions up to, and including, 0.9 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page."}],"affected":[{"vendor":"remko","product":"WP BookWidgets","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"0.9","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/1716743f-8259-40fb-bc9b-53e3dfef8816?source=cve"},{"url":"https://plugins.trac.wordpress.org/browser/wp-bookwidgets/trunk/wp-bookwidgets.php#L163"},{"url":"https://wordpress.org/plugins/wp-bookwidgets"},{"url":"https://plugins.trac.wordpress.org/changeset/3380322/"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","baseScore":6.4,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","lang":"en","description":"CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T16:37:17.825Z"},"credits":[{"lang":"en","type":"finder","value":"Djaidja Moundjid"}],"timeline":[{"time":"2025-10-14T20:01:01.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-10-15T15:29:21.638513Z","id":"CVE-2025-10139","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-10-15T15:49:11.358Z"}}]}}}