{"id":"CVE-2025-0914","state":"PUBLISHED","title":"Velociraptor Shell Plugin Prevent_execve Bypass","description":"An improper access control issue in the VQL shell feature in Velociraptor Versions < 0.73.4 allowed authenticated users to execute the execve() plugin in deployments where this was explicitly forbidden by configuring the prevent_execve flag in the configuration file. This setting is not usually recommended and is uncommonly used, so this issue will only affect users who do set it. This issue is fixed in release 0.73.4.","publishedAt":"2025-02-27T16:07:49.577Z","updatedAt":"2025-02-27T16:19:54.044Z","severity":{"score":3.8,"label":"Low","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:N","source":"rapid7"},"assigner":"rapid7","products":["Rapid7 Velociraptor"],"affected":[{"vendor":"Rapid7","product":"Velociraptor","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThan":"0.73.4","versionType":"semver"}]}],"references":["https://docs.velociraptor.app/announcements/advisories/cve-2025-0914/"],"weaknesses":["CWE-281"],"ingestedAt":"2026-10-29T20:08:20.985Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2025/0xxx/CVE-2025-0914.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2025-0914","state":"PUBLISHED","datePublished":"2025-02-27T16:07:49.577Z","dateUpdated":"2025-02-27T16:19:54.044Z","assignerShortName":"rapid7","assignerOrgId":"9974b330-7714-4307-a722-5648477acda7","dateReserved":"2025-01-30T22:39:47.257Z"},"containers":{"cna":{"title":"Velociraptor Shell Plugin Prevent_execve Bypass","descriptions":[{"lang":"en","value":"An improper access control issue in the VQL shell feature in Velociraptor Versions < 0.73.4 allowed authenticated users to execute the execve() plugin in deployments where this was explicitly forbidden by configuring the prevent_execve flag in the configuration file. This setting is not usually recommended and is uncommonly used, so this issue will only affect users who do set it. This issue is fixed in release 0.73.4."}],"affected":[{"vendor":"Rapid7","product":"Velociraptor","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThan":"0.73.4","versionType":"semver"}]}],"references":[{"url":"https://docs.velociraptor.app/announcements/advisories/cve-2025-0914/"}],"metrics":[{"cvssV3_1":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"NONE","baseScore":3.8,"baseSeverity":"LOW","confidentialityImpact":"LOW","integrityImpact":"LOW","privilegesRequired":"HIGH","scope":"UNCHANGED","userInteraction":"NONE","vectorString":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:N","version":"3.1"},"format":"CVSS","scenarios":[{"lang":"en","value":"GENERAL"}]}],"problemTypes":[{"descriptions":[{"cweId":"CWE-281","description":"CWE-281 Improper Preservation of Permissions","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"rapid7","orgId":"9974b330-7714-4307-a722-5648477acda7","dateUpdated":"2025-02-27T16:07:49.577Z"},"credits":[{"lang":"en","type":"finder","value":"Darragh O'Reilly, SUSE"}],"impacts":[{"capecId":"CAPEC-176","descriptions":[{"lang":"en","value":"CAPEC-176 Configuration/Environment Manipulation"}]}],"source":{"discovery":"EXTERNAL"},"x_generator":{"engine":"Vulnogram 0.2.0"}},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-02-27T16:19:47.398915Z","id":"CVE-2025-0914","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-02-27T16:19:54.044Z"}}]}}}