{"id":"CVE-2024-9943","state":"PUBLISHED","title":"MultiVendorX – The Ultimate WooCommerce Multivendor Marketplace Solution <= 4.2.4 - Cross-Site Request Forgery to Vendor Updates","description":"The MultiVendorX – The Ultimate WooCommerce Multivendor Marketplace Solution plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 4.2.4. This is due to missing or incorrect nonce validation on several functions in api/class-mvx-rest-controller.php. This makes it possible for unauthenticated attackers to update vendor account details, create vendor accounts, and delete arbitrary users via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.","publishedAt":"2024-10-24T07:35:57.226Z","updatedAt":"2026-04-08T17:17:59.416Z","severity":{"score":6.3,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L","source":"Wordfence"},"assigner":"Wordfence","products":["wcmp MultiVendorX – WooCommerce Multivendor Marketplace Solutions"],"affected":[{"vendor":"wcmp","product":"MultiVendorX – WooCommerce Multivendor Marketplace Solutions","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"4.2.4","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/b950faf9-2122-42af-9f05-ec850767be32?source=cve","https://plugins.trac.wordpress.org/browser/dc-woocommerce-multi-vendor/tags/4.2.1/api/class-mvx-rest-controller.php#L5258","https://plugins.trac.wordpress.org/browser/dc-woocommerce-multi-vendor/tags/4.2.1/api/class-mvx-rest-controller.php#L6155","https://plugins.trac.wordpress.org/browser/dc-woocommerce-multi-vendor/tags/4.2.1/api/class-mvx-rest-controller.php#L6009","https://plugins.trac.wordpress.org/changeset/3173238/dc-woocommerce-multi-vendor/trunk/api/class-mvx-rest-controller.php?old=3168957&old_path=dc-woocommerce-multi-vendor%2Ftrunk%2Fapi%2Fclass-mvx-rest-controller.php"],"weaknesses":["CWE-352"],"ingestedAt":"2026-10-29T20:08:20.985Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2024/9xxx/CVE-2024-9943.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2024-9943","state":"PUBLISHED","datePublished":"2024-10-24T07:35:57.226Z","dateUpdated":"2026-04-08T17:17:59.416Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2024-10-14T16:52:22.254Z"},"containers":{"cna":{"title":"MultiVendorX – The Ultimate WooCommerce Multivendor Marketplace Solution <= 4.2.4 - Cross-Site Request Forgery to Vendor Updates","descriptions":[{"lang":"en","value":"The MultiVendorX – The Ultimate WooCommerce Multivendor Marketplace Solution plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 4.2.4. This is due to missing or incorrect nonce validation on several functions in api/class-mvx-rest-controller.php. This makes it possible for unauthenticated attackers to update vendor account details, create vendor accounts, and delete arbitrary users via a forged request granted they can trick a site administrator into performing an action such as clicking on a link."}],"affected":[{"vendor":"wcmp","product":"MultiVendorX – WooCommerce Multivendor Marketplace Solutions","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"4.2.4","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/b950faf9-2122-42af-9f05-ec850767be32?source=cve"},{"url":"https://plugins.trac.wordpress.org/browser/dc-woocommerce-multi-vendor/tags/4.2.1/api/class-mvx-rest-controller.php#L5258"},{"url":"https://plugins.trac.wordpress.org/browser/dc-woocommerce-multi-vendor/tags/4.2.1/api/class-mvx-rest-controller.php#L6155"},{"url":"https://plugins.trac.wordpress.org/browser/dc-woocommerce-multi-vendor/tags/4.2.1/api/class-mvx-rest-controller.php#L6009"},{"url":"https://plugins.trac.wordpress.org/changeset/3173238/dc-woocommerce-multi-vendor/trunk/api/class-mvx-rest-controller.php?old=3168957&old_path=dc-woocommerce-multi-vendor%2Ftrunk%2Fapi%2Fclass-mvx-rest-controller.php"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L","baseScore":6.3,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-352","lang":"en","description":"CWE-352 Cross-Site Request Forgery (CSRF)","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T17:17:59.416Z"},"credits":[{"lang":"en","type":"finder","value":"wesley"}],"timeline":[{"time":"2024-10-23T19:21:58.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2024-10-24T18:59:01.484110Z","id":"CVE-2024-9943","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2024-10-24T18:59:14.959Z"}}]}}}