{"id":"CVE-2024-9664","state":"PUBLISHED","title":"WP All Import Pro <= 4.9.7 - Authenticated (Administrator+) PHP Object Injection via Import File","description":"The WP All Import Pro plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 4.9.7 via deserialization of untrusted input from an import file. This makes it possible for authenticated attackers, with Administrator-level access and above, to inject a PHP Object. No known POP chain is present in the vulnerable software. If a POP chain is present via an additional plugin or theme installed on the target system, it could allow the attacker to delete arbitrary files, retrieve sensitive data, or execute code.","publishedAt":"2025-02-07T15:21:04.505Z","updatedAt":"2026-04-08T16:32:20.720Z","severity":{"score":7.2,"label":"High","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H","source":"Wordfence"},"assigner":"Wordfence","products":["Soflyy WP All Import Pro"],"affected":[{"vendor":"Soflyy","product":"WP All Import Pro","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"4.9.7","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/0099a8d7-827d-4215-9a2b-b3c268fb5e97?source=cve","https://www.wpallimport.com/"],"weaknesses":["CWE-502"],"ingestedAt":"2026-10-29T20:08:20.985Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2024/9xxx/CVE-2024-9664.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2024-9664","state":"PUBLISHED","datePublished":"2025-02-07T15:21:04.505Z","dateUpdated":"2026-04-08T16:32:20.720Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2024-10-08T21:34:30.089Z"},"containers":{"cna":{"title":"WP All Import Pro <= 4.9.7 - Authenticated (Administrator+) PHP Object Injection via Import File","descriptions":[{"lang":"en","value":"The WP All Import Pro plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 4.9.7 via deserialization of untrusted input from an import file. This makes it possible for authenticated attackers, with Administrator-level access and above, to inject a PHP Object. No known POP chain is present in the vulnerable software. If a POP chain is present via an additional plugin or theme installed on the target system, it could allow the attacker to delete arbitrary files, retrieve sensitive data, or execute code."}],"affected":[{"vendor":"Soflyy","product":"WP All Import Pro","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"4.9.7","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/0099a8d7-827d-4215-9a2b-b3c268fb5e97?source=cve"},{"url":"https://www.wpallimport.com/"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H","baseScore":7.2,"baseSeverity":"HIGH"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-502","lang":"en","description":"CWE-502 Deserialization of Untrusted Data","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T16:32:20.720Z"},"credits":[{"lang":"en","type":"finder","value":"Francesco Carlucci"}],"timeline":[{"time":"2024-08-10T00:00:00.000Z","lang":"en","value":"Discovered"},{"time":"2024-08-10T00:00:00.000Z","lang":"en","value":"Vendor Notified"},{"time":"2025-02-07T03:05:08.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-02-07T15:31:43.277634Z","id":"CVE-2024-9664","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"total"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-02-07T15:32:12.342Z"}}]}}}