{"id":"CVE-2024-9613","state":"PUBLISHED","title":"FormFacade – WordPress plugin for Google Forms <= 1.3.6 - Reflected Cross-Site Scripting","description":"The FormFacade – WordPress plugin for Google Forms plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'userId' and 'publishId' parameters in all versions up to, and including, 1.3.6 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.","publishedAt":"2024-10-26T02:31:32.274Z","updatedAt":"2026-04-08T17:29:39.964Z","severity":{"score":6.1,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["manidoraisamy FormFacade – Embed Google Forms in your website"],"affected":[{"vendor":"manidoraisamy","product":"FormFacade – Embed Google Forms in your website","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"1.3.6","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/e4a00ad0-5761-4fb7-a4e6-cb213cf32cb2?source=cve","https://plugins.trac.wordpress.org/browser/formfacade/trunk/formfacade.php#L173","https://plugins.trac.wordpress.org/changeset/3182047/formfacade/trunk/formfacade.php"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T20:08:20.985Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2024/9xxx/CVE-2024-9613.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2024-9613","state":"PUBLISHED","datePublished":"2024-10-26T02:31:32.274Z","dateUpdated":"2026-04-08T17:29:39.964Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2024-10-07T22:24:46.859Z"},"containers":{"cna":{"title":"FormFacade – WordPress plugin for Google Forms <= 1.3.6 - Reflected Cross-Site Scripting","descriptions":[{"lang":"en","value":"The FormFacade – WordPress plugin for Google Forms plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'userId' and 'publishId' parameters in all versions up to, and including, 1.3.6 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link."}],"affected":[{"vendor":"manidoraisamy","product":"FormFacade – Embed Google Forms in your website","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"1.3.6","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/e4a00ad0-5761-4fb7-a4e6-cb213cf32cb2?source=cve"},{"url":"https://plugins.trac.wordpress.org/browser/formfacade/trunk/formfacade.php#L173"},{"url":"https://plugins.trac.wordpress.org/changeset/3182047/formfacade/trunk/formfacade.php"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","baseScore":6.1,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","lang":"en","description":"CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T17:29:39.964Z"},"credits":[{"lang":"en","type":"finder","value":"vgo0"}],"timeline":[{"time":"2024-10-25T13:59:02.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","affected":[{"vendor":"manidoraisamy","product":"formfacade","defaultStatus":"unknown","versions":[{"version":"0","status":"affected","lessThanOrEqual":"1.3.6","versionType":"semver"}],"cpes":["cpe:2.3:a:manidoraisamy:formfacade:*:*:*:*:*:*:*:*"]}],"metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2024-10-28T17:34:02.355293Z","id":"CVE-2024-9613","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"total"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2024-10-28T17:37:23.501Z"}}]}}}