{"id":"CVE-2024-9542","state":"PUBLISHED","title":"Sky Addons for Elementor <= 2.6.1 - Authenticated (Contributor+) Sensitive Information Exposure via Content Switcher Widget Elementor Template","description":"The Sky Addons for Elementor plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 2.6.1 via the render function in modules/content-switcher/widgets/content-switcher.php. This makes it possible for authenticated attackers, with Contributor-level access and above, to extract sensitive private, pending, and draft Elementor template data.","publishedAt":"2024-11-21T11:02:19.986Z","updatedAt":"2026-04-08T16:46:56.443Z","severity":{"score":4.3,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["wowdevs Sky Addons – Elementor Addons with Widgets & Templates"],"affected":[{"vendor":"wowdevs","product":"Sky Addons – Elementor Addons with Widgets & Templates","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"2.6.1","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/3a0d9356-8083-4154-aa04-9008627dd3f5?source=cve","https://plugins.trac.wordpress.org/changeset/3189030/sky-elementor-addons"],"weaknesses":["CWE-200"],"ingestedAt":"2026-10-29T20:08:20.985Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2024/9xxx/CVE-2024-9542.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2024-9542","state":"PUBLISHED","datePublished":"2024-11-21T11:02:19.986Z","dateUpdated":"2026-04-08T16:46:56.443Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2024-10-04T19:01:49.548Z"},"containers":{"cna":{"title":"Sky Addons for Elementor <= 2.6.1 - Authenticated (Contributor+) Sensitive Information Exposure via Content Switcher Widget Elementor Template","descriptions":[{"lang":"en","value":"The Sky Addons for Elementor plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 2.6.1 via the render function in modules/content-switcher/widgets/content-switcher.php. This makes it possible for authenticated attackers, with Contributor-level access and above, to extract sensitive private, pending, and draft Elementor template data."}],"affected":[{"vendor":"wowdevs","product":"Sky Addons – Elementor Addons with Widgets & Templates","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"2.6.1","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/3a0d9356-8083-4154-aa04-9008627dd3f5?source=cve"},{"url":"https://plugins.trac.wordpress.org/changeset/3189030/sky-elementor-addons"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N","baseScore":4.3,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-200","lang":"en","description":"CWE-200 Exposure of Sensitive Information to an Unauthorized Actor","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T16:46:56.443Z"},"credits":[{"lang":"en","type":"finder","value":"Nirmal"}],"timeline":[{"time":"2024-10-09T00:00:00.000Z","lang":"en","value":"Vendor Notified"},{"time":"2024-11-20T00:00:00.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"id":"CVE-2024-9542","role":"CISA Coordinator","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"version":"2.0.3","timestamp":"2024-11-21T13:58:19.374800Z"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2024-11-21T14:00:31.457Z"}}]}}}