{"id":"CVE-2024-9265","state":"PUBLISHED","title":"Echo RSS Feed Post Generator <= 5.4.6 - Unauthenticated Privilege Escalation","description":"The Echo RSS Feed Post Generator plugin for WordPress is vulnerable to privilege escalation in all versions up to, and including, 5.4.6. This is due to the plugin not properly restricting the roles that can set during registration through the echo_check_post_header_sent() function. This makes it possible for unauthenticated attackers to register as an administrator.","publishedAt":"2024-10-01T08:30:18.477Z","updatedAt":"2026-04-08T17:19:39.747Z","severity":{"score":9.8,"label":"Critical","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","source":"Wordfence"},"assigner":"Wordfence","products":["CodeRevolution Echo RSS Feed Post Generator"],"affected":[{"vendor":"CodeRevolution","product":"Echo RSS Feed Post Generator","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"5.4.6","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/c099f401-4b05-4532-8e31-af1b1dea7eca?source=cve","https://codecanyon.net/item/echo-rss-feed-post-generator-plugin-for-wordpress/19486974"],"weaknesses":["CWE-269"],"ingestedAt":"2026-10-29T20:08:20.985Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2024/9xxx/CVE-2024-9265.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2024-9265","state":"PUBLISHED","datePublished":"2024-10-01T08:30:18.477Z","dateUpdated":"2026-04-08T17:19:39.747Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2024-09-26T20:30:45.737Z"},"containers":{"cna":{"title":"Echo RSS Feed Post Generator <= 5.4.6 - Unauthenticated Privilege Escalation","descriptions":[{"lang":"en","value":"The Echo RSS Feed Post Generator plugin for WordPress is vulnerable to privilege escalation in all versions up to, and including, 5.4.6. This is due to the plugin not properly restricting the roles that can set during registration through the echo_check_post_header_sent() function. This makes it possible for unauthenticated attackers to register as an administrator."}],"affected":[{"vendor":"CodeRevolution","product":"Echo RSS Feed Post Generator","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"5.4.6","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/c099f401-4b05-4532-8e31-af1b1dea7eca?source=cve"},{"url":"https://codecanyon.net/item/echo-rss-feed-post-generator-plugin-for-wordpress/19486974"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","baseScore":9.8,"baseSeverity":"CRITICAL"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-269","lang":"en","description":"CWE-269 Improper Privilege Management","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T17:19:39.747Z"},"credits":[{"lang":"en","type":"finder","value":"Tonn"}],"timeline":[{"time":"2024-09-30T00:00:00.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","affected":[{"vendor":"coderevolution","product":"echo_rss_feed_post_generator","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"5.4.6","versionType":"semver"}],"cpes":["cpe:2.3:a:coderevolution:echo_rss_feed_post_generator:*:*:*:*:*:*:*:*"]}],"metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2024-10-01T13:30:45.788638Z","id":"CVE-2024-9265","options":[{"Exploitation":"none"},{"Automatable":"yes"},{"Technical Impact":"total"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2024-10-01T13:31:58.423Z"}}]}}}