{"id":"CVE-2024-8547","state":"PUBLISHED","title":"Simple Popup Plugin <= 4.5 - Authenticated (Contributor+) Stored Cross-Site Scripting","description":"The Simple Popup Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's [popup] shortcode in all versions up to, and including, 4.5 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.","publishedAt":"2024-09-28T02:04:20.011Z","updatedAt":"2026-04-08T16:41:26.980Z","severity":{"score":6.4,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["grimmdude Simple Popup Plugin"],"affected":[{"vendor":"grimmdude","product":"Simple Popup Plugin","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"4.5","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/217da4de-38df-41ff-b138-f12d4f8999cd?source=cve","https://plugins.trac.wordpress.org/browser/simple-popup-plugin/tags/4.5/simple_popup_plugin.php#L87","https://plugins.trac.wordpress.org/changeset/3160218/#file7"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T20:08:20.985Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2024/8xxx/CVE-2024-8547.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2024-8547","state":"PUBLISHED","datePublished":"2024-09-28T02:04:20.011Z","dateUpdated":"2026-04-08T16:41:26.980Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2024-09-06T19:15:14.386Z"},"containers":{"cna":{"title":"Simple Popup Plugin <= 4.5 - Authenticated (Contributor+) Stored Cross-Site Scripting","descriptions":[{"lang":"en","value":"The Simple Popup Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's [popup] shortcode in all versions up to, and including, 4.5 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page."}],"affected":[{"vendor":"grimmdude","product":"Simple Popup Plugin","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"4.5","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/217da4de-38df-41ff-b138-f12d4f8999cd?source=cve"},{"url":"https://plugins.trac.wordpress.org/browser/simple-popup-plugin/tags/4.5/simple_popup_plugin.php#L87"},{"url":"https://plugins.trac.wordpress.org/changeset/3160218/#file7"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","baseScore":6.4,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","lang":"en","description":"CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T16:41:26.980Z"},"credits":[{"lang":"en","type":"finder","value":"Krzysztof Zając"}],"timeline":[{"time":"2024-09-27T13:55:41.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2024-09-30T14:31:46.784375Z","id":"CVE-2024-8547","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2024-09-30T15:26:07.105Z"}}]}}}