{"id":"CVE-2024-6283","state":"PUBLISHED","title":"DethemeKit For Elementor <= 2.1.5 - Authenticated (Contributor+) Stored Cross-Site Scripting via URL Parameter of the De Gallery Widget","description":"The DethemeKit For Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the URL parameter of the De Gallery widget in all versions up to and including 2.1.5 due to insufficient input sanitization and output escaping on user-supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user clicks on the injected link.","publishedAt":"2024-06-27T04:38:47.998Z","updatedAt":"2026-04-08T17:11:12.675Z","severity":{"score":5.4,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["detheme DethemeKit for Elementor"],"affected":[{"vendor":"detheme","product":"DethemeKit for Elementor","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"2.1.5","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/9b2083f9-79d0-43f6-b7ae-a5817dc561b0?source=cve","https://plugins.trac.wordpress.org/browser/dethemekit-for-elementor/trunk/widgets/dethemekit-grid.php#L2565","https://plugins.trac.wordpress.org/browser/dethemekit-for-elementor/trunk/widgets/dethemekit-grid.php#L2900"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T20:08:12.933Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2024/6xxx/CVE-2024-6283.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2024-6283","state":"PUBLISHED","datePublished":"2024-06-27T04:38:47.998Z","dateUpdated":"2026-04-08T17:11:12.675Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2024-06-24T10:56:16.783Z"},"containers":{"cna":{"title":"DethemeKit For Elementor <= 2.1.5 - Authenticated (Contributor+) Stored Cross-Site Scripting via URL Parameter of the De Gallery Widget","descriptions":[{"lang":"en","value":"The DethemeKit For Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the URL parameter of the De Gallery widget in all versions up to and including 2.1.5 due to insufficient input sanitization and output escaping on user-supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user clicks on the injected link."}],"affected":[{"vendor":"detheme","product":"DethemeKit for Elementor","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"2.1.5","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/9b2083f9-79d0-43f6-b7ae-a5817dc561b0?source=cve"},{"url":"https://plugins.trac.wordpress.org/browser/dethemekit-for-elementor/trunk/widgets/dethemekit-grid.php#L2565"},{"url":"https://plugins.trac.wordpress.org/browser/dethemekit-for-elementor/trunk/widgets/dethemekit-grid.php#L2900"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","baseScore":5.4,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","lang":"en","description":"CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T17:11:12.675Z"},"credits":[{"lang":"en","type":"finder","value":"Craig Smith"}],"timeline":[{"time":"2024-06-14T00:00:00.000Z","lang":"en","value":"Discovered"},{"time":"2024-06-26T16:37:22.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2024-06-27T18:14:46.692788Z","id":"CVE-2024-6283","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2024-06-27T18:14:54.867Z"}},{"title":"CVE Program Container","references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/9b2083f9-79d0-43f6-b7ae-a5817dc561b0?source=cve","tags":["x_transferred"]},{"url":"https://plugins.trac.wordpress.org/browser/dethemekit-for-elementor/trunk/widgets/dethemekit-grid.php#L2565","tags":["x_transferred"]},{"url":"https://plugins.trac.wordpress.org/browser/dethemekit-for-elementor/trunk/widgets/dethemekit-grid.php#L2900","tags":["x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-01T21:33:05.519Z"}}]}}}