{"id":"CVE-2024-56339","state":"PUBLISHED","title":"IBM WebSphere Application Server information disclosure","description":"IBM WebSphere Application Server 9.0 and WebSphere Application Server Liberty 17.0.0.3 through 25.0.0.7 could allow a remote attacker to bypass security restrictions caused by a failure to honor security configuration.","publishedAt":"2025-08-07T16:03:05.256Z","updatedAt":"2025-08-07T16:29:34.336Z","severity":{"score":3.7,"label":"Low","version":"3.1","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N","source":"ibm"},"assigner":"ibm","products":["IBM WebSphere Application Server","IBM WebSphere Application Server Liberty"],"affected":[{"vendor":"IBM","product":"WebSphere Application Server","defaultStatus":"unaffected","versions":[{"version":"9.0","status":"affected","versionType":"semver"}],"cpes":["cpe:2.3:a:ibm:websphere_application_server:9.0:*:*:*:*:*:*:*"]},{"vendor":"IBM","product":"WebSphere Application Server Liberty","defaultStatus":"unaffected","versions":[{"version":"17.0.0.3","status":"affected","lessThanOrEqual":"25.0.0.7","versionType":"semver"}],"cpes":["cpe:2.3:a:ibm:websphere_application_server:17.0.0.3:*:*:*:liberty:*:*:*","cpe:2.3:a:ibm:websphere_application_server:25.0.0.7:*:*:*:liberty:*:*:*"]}],"references":["https://www.ibm.com/support/pages/node/7239955"],"weaknesses":["CWE-650"],"ingestedAt":"2026-10-29T20:08:12.933Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2024/56xxx/CVE-2024-56339.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2024-56339","state":"PUBLISHED","datePublished":"2025-08-07T16:03:05.256Z","dateUpdated":"2025-08-07T16:29:34.336Z","assignerShortName":"ibm","assignerOrgId":"9a959283-ebb5-44b6-b705-dcc2bbced522","dateReserved":"2024-12-20T13:55:07.212Z"},"containers":{"cna":{"title":"IBM WebSphere Application Server information disclosure","descriptions":[{"lang":"en","value":"IBM WebSphere Application Server 9.0 and WebSphere Application Server Liberty 17.0.0.3 through 25.0.0.7 could allow a remote attacker to bypass security restrictions caused by a failure to honor security configuration."}],"affected":[{"vendor":"IBM","product":"WebSphere Application Server","defaultStatus":"unaffected","versions":[{"version":"9.0","status":"affected","versionType":"semver"}],"cpes":["cpe:2.3:a:ibm:websphere_application_server:9.0:*:*:*:*:*:*:*"]},{"vendor":"IBM","product":"WebSphere Application Server Liberty","defaultStatus":"unaffected","versions":[{"version":"17.0.0.3","status":"affected","lessThanOrEqual":"25.0.0.7","versionType":"semver"}],"cpes":["cpe:2.3:a:ibm:websphere_application_server:17.0.0.3:*:*:*:liberty:*:*:*","cpe:2.3:a:ibm:websphere_application_server:25.0.0.7:*:*:*:liberty:*:*:*"]}],"references":[{"url":"https://www.ibm.com/support/pages/node/7239955","tags":["vendor-advisory","patch"]}],"metrics":[{"cvssV3_1":{"attackComplexity":"HIGH","attackVector":"NETWORK","availabilityImpact":"NONE","baseScore":3.7,"baseSeverity":"LOW","confidentialityImpact":"LOW","integrityImpact":"NONE","privilegesRequired":"NONE","scope":"UNCHANGED","userInteraction":"NONE","vectorString":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"format":"CVSS","scenarios":[{"lang":"en","value":"GENERAL"}]}],"problemTypes":[{"descriptions":[{"cweId":"CWE-650","description":"CWE-650","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"ibm","orgId":"9a959283-ebb5-44b6-b705-dcc2bbced522","dateUpdated":"2025-08-07T16:11:38.908Z"},"solutions":[{"lang":"en","supportingMedia":[{"base64":false,"type":"text/html","value":"For IBM WebSphere Application Server Liberty 17.0.0.3 - 25.0.0.7 using the servlet-3.1, servlet-4.0, servlet-5.0 or servlet-6.0 feature:<br><br>· Upgrade to minimal fix pack levels as required by the interim fix and then apply the Interim Fix that resolves PH64682 <br>--OR--<br>· Apply Fix Pack 25.0.0.8 or later (targeted availability 3Q2025).<br><br>For IBM WebSphere Application Server traditional:<br><br>For V9.0.0.0 through 9.0.5.24:<br>· Upgrade to minimal fix pack levels as required by the interim fix and then apply the Interim Fix that resolves PH64683 <br>--OR--<br>· Apply Fix Pack 9.0.5.26 or later (targeted availability 4Q2025).  <br><br> <br><br>Additional interim fixes may be available and linked off the interim fix download page.<br>"}],"value":"For IBM WebSphere Application Server Liberty 17.0.0.3 - 25.0.0.7 using the servlet-3.1, servlet-4.0, servlet-5.0 or servlet-6.0 feature:\n\n· Upgrade to minimal fix pack levels as required by the interim fix and then apply the Interim Fix that resolves PH64682 \n--OR--\n· Apply Fix Pack 25.0.0.8 or later (targeted availability 3Q2025).\n\nFor IBM WebSphere Application Server traditional:\n\nFor V9.0.0.0 through 9.0.5.24:\n· Upgrade to minimal fix pack levels as required by the interim fix and then apply the Interim Fix that resolves PH64683 \n--OR--\n· Apply Fix Pack 9.0.5.26 or later (targeted availability 4Q2025).  \n\n \n\nAdditional interim fixes may be available and linked off the interim fix download page."}],"source":{"discovery":"UNKNOWN"},"x_generator":{"engine":"Vulnogram 0.2.0"}},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-08-07T16:29:27.157409Z","id":"CVE-2024-56339","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-08-07T16:29:34.336Z"}}]}}}