{"id":"CVE-2024-55954","state":"PUBLISHED","title":"OpenObserve Improper Authorization Allows Admin User to Remove Root User","description":"OpenObserve is a cloud-native observability platform. A vulnerability in the user management endpoint `/api/{org_id}/users/{email_id}` allows an \"Admin\" role user to remove a \"Root\" user from the organization. This violates the intended privilege hierarchy, enabling a non-root user to remove the highest-privileged account. Due to insufficient role checks, the `remove_user_from_org` function does not prevent an \"Admin\" user from removing a \"Root\" user. As a result, an attacker with an \"Admin\" role can remove critical \"Root\" users, potentially gaining effective full control by eliminating the highest-privileged accounts. The `DELETE /api/{org_id}/users/{email_id}` endpoint is affected. This issue has been addressed in release version `0.14.1` and all users are advised to upgrade. There are no known workarounds for this vulnerability.","publishedAt":"2025-01-16T19:30:39.218Z","updatedAt":"2025-02-12T20:31:21.093Z","severity":{"score":8.7,"label":"High","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:N","source":"GitHub_M"},"assigner":"GitHub_M","products":["openobserve openobserve"],"affected":[{"vendor":"openobserve","product":"openobserve","versions":[{"version":"< 0.14.1","status":"affected"}]}],"references":["https://github.com/openobserve/openobserve/security/advisories/GHSA-m8gj-6r85-3r6m","https://github.com/gaby/openobserve/blob/main/src/service/users.rs#L631"],"weaknesses":["CWE-269","CWE-272","CWE-284","CWE-285","CWE-287"],"ingestedAt":"2026-10-29T20:08:04.920Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2024/55xxx/CVE-2024-55954.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2024-55954","state":"PUBLISHED","datePublished":"2025-01-16T19:30:39.218Z","dateUpdated":"2025-02-12T20:31:21.093Z","assignerShortName":"GitHub_M","assignerOrgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateReserved":"2024-12-13T17:47:38.371Z"},"containers":{"cna":{"title":"OpenObserve Improper Authorization Allows Admin User to Remove Root User","descriptions":[{"lang":"en","value":"OpenObserve is a cloud-native observability platform. A vulnerability in the user management endpoint `/api/{org_id}/users/{email_id}` allows an \"Admin\" role user to remove a \"Root\" user from the organization. This violates the intended privilege hierarchy, enabling a non-root user to remove the highest-privileged account. Due to insufficient role checks, the `remove_user_from_org` function does not prevent an \"Admin\" user from removing a \"Root\" user. As a result, an attacker with an \"Admin\" role can remove critical \"Root\" users, potentially gaining effective full control by eliminating the highest-privileged accounts. The `DELETE /api/{org_id}/users/{email_id}` endpoint is affected. This issue has been addressed in release version `0.14.1` and all users are advised to upgrade. There are no known workarounds for this vulnerability."}],"affected":[{"vendor":"openobserve","product":"openobserve","versions":[{"version":"< 0.14.1","status":"affected"}]}],"references":[{"url":"https://github.com/openobserve/openobserve/security/advisories/GHSA-m8gj-6r85-3r6m","name":"https://github.com/openobserve/openobserve/security/advisories/GHSA-m8gj-6r85-3r6m","tags":["x_refsource_CONFIRM"]},{"url":"https://github.com/gaby/openobserve/blob/main/src/service/users.rs#L631","name":"https://github.com/gaby/openobserve/blob/main/src/service/users.rs#L631","tags":["x_refsource_MISC"]}],"metrics":[{"cvssV3_1":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"NONE","baseScore":8.7,"baseSeverity":"HIGH","confidentialityImpact":"HIGH","integrityImpact":"HIGH","privilegesRequired":"HIGH","scope":"CHANGED","userInteraction":"NONE","vectorString":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:N","version":"3.1"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-269","lang":"en","description":"CWE-269: Improper Privilege Management","type":"CWE"}]},{"descriptions":[{"cweId":"CWE-272","lang":"en","description":"CWE-272: Least Privilege Violation","type":"CWE"}]},{"descriptions":[{"cweId":"CWE-284","lang":"en","description":"CWE-284: Improper Access Control","type":"CWE"}]},{"descriptions":[{"cweId":"CWE-285","lang":"en","description":"CWE-285: Improper Authorization","type":"CWE"}]},{"descriptions":[{"cweId":"CWE-287","lang":"en","description":"CWE-287: Improper Authentication","type":"CWE"}]}],"providerMetadata":{"shortName":"GitHub_M","orgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateUpdated":"2025-01-16T19:30:39.218Z"},"source":{"advisory":"GHSA-m8gj-6r85-3r6m","discovery":"UNKNOWN"}},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"id":"CVE-2024-55954","role":"CISA Coordinator","options":[{"Exploitation":"poc"},{"Automatable":"no"},{"Technical Impact":"total"}],"version":"2.0.3","timestamp":"2025-01-16T19:48:06.639039Z"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-02-12T20:31:21.093Z"}}]}}}