{"id":"CVE-2024-55633","state":"PUBLISHED","title":"Apache Superset: SQLLab Improper readonly query validation allows unauthorized write access","description":"Improper Authorization vulnerability in Apache Superset. On Postgres analytic databases an attacker with SQLLab access can craft a specially designed SQL DML statement that is Incorrectly identified as a read-only query, enabling its execution. Non postgres analytics database connections and postgres analytics database connections set with a readonly user (advised) are not vulnerable. \n\nThis issue affects Apache Superset: before 4.1.0.\n\nUsers are recommended to upgrade to version 4.1.0, which fixes the issue.","publishedAt":"2024-12-12T14:36:02.325Z","updatedAt":"2025-02-12T09:35:43.626Z","severity":{"score":7.1,"label":"High","version":"4.0","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N","source":"apache"},"assigner":"apache","products":["Apache Software Foundation Apache Superset"],"affected":[{"vendor":"Apache Software Foundation","product":"Apache Superset","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThan":"4.1.0","versionType":"semver"}]}],"references":["https://lists.apache.org/thread/bwmd17fcvljt9q4cgctp4v09zh3qs7fb","http://www.openwall.com/lists/oss-security/2024/12/12/1"],"weaknesses":["CWE-863"],"ingestedAt":"2026-10-29T20:08:04.920Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2024/55xxx/CVE-2024-55633.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2024-55633","state":"PUBLISHED","datePublished":"2024-12-12T14:36:02.325Z","dateUpdated":"2025-02-12T09:35:43.626Z","assignerShortName":"apache","assignerOrgId":"f0158376-9dc2-43b6-827c-5f631a4d8d09","dateReserved":"2024-12-09T21:48:12.343Z"},"containers":{"cna":{"title":"Apache Superset: SQLLab Improper readonly query validation allows unauthorized write access","descriptions":[{"lang":"en","value":"Improper Authorization vulnerability in Apache Superset. On Postgres analytic databases an attacker with SQLLab access can craft a specially designed SQL DML statement that is Incorrectly identified as a read-only query, enabling its execution. Non postgres analytics database connections and postgres analytics database connections set with a readonly user (advised) are not vulnerable. \n\nThis issue affects Apache Superset: before 4.1.0.\n\nUsers are recommended to upgrade to version 4.1.0, which fixes the issue."}],"affected":[{"vendor":"Apache Software Foundation","product":"Apache Superset","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThan":"4.1.0","versionType":"semver"}]}],"references":[{"url":"https://lists.apache.org/thread/bwmd17fcvljt9q4cgctp4v09zh3qs7fb","tags":["vendor-advisory"]}],"metrics":[{"cvssV4_0":{"Automatable":"NOT_DEFINED","Recovery":"NOT_DEFINED","Safety":"NOT_DEFINED","attackComplexity":"LOW","attackRequirements":"NONE","attackVector":"NETWORK","baseScore":7.1,"baseSeverity":"HIGH","privilegesRequired":"LOW","providerUrgency":"NOT_DEFINED","subAvailabilityImpact":"NONE","subConfidentialityImpact":"NONE","subIntegrityImpact":"NONE","userInteraction":"NONE","valueDensity":"NOT_DEFINED","vectorString":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N","version":"4.0","vulnAvailabilityImpact":"NONE","vulnConfidentialityImpact":"NONE","vulnIntegrityImpact":"HIGH","vulnerabilityResponseEffort":"NOT_DEFINED"},"format":"CVSS","scenarios":[{"lang":"en","value":"GENERAL"}]}],"problemTypes":[{"descriptions":[{"cweId":"CWE-863","description":"CWE-863 Incorrect Authorization","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"apache","orgId":"f0158376-9dc2-43b6-827c-5f631a4d8d09","dateUpdated":"2025-02-12T09:35:43.626Z"},"credits":[{"lang":"en","type":"remediation developer","value":"Beto de Almeida"},{"lang":"en","type":"coordinator","value":"Daniel Gaspar"},{"lang":"en","type":"finder","value":"James Ford (Striveworks)"}],"source":{"discovery":"UNKNOWN"},"x_generator":{"engine":"Vulnogram 0.2.0"}},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2024-12-12T15:27:53.132335Z","id":"CVE-2024-55633","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2024-12-12T15:28:06.454Z"}},{"title":"CVE Program Container","references":[{"url":"http://www.openwall.com/lists/oss-security/2024/12/12/1"}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-12-12T18:03:30.295Z"}}]}}}