{"id":"CVE-2024-5326","state":"PUBLISHED","title":"Post Grid Gutenberg Blocks and WordPress Blog Plugin – PostX <= 4.1.2 - Missing Authorization to Arbitrary Options Update","description":"The Post Grid Gutenberg Blocks and WordPress Blog Plugin – PostX plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the 'postx_presets_callback' function in all versions up to, and including, 4.1.2. This makes it possible for authenticated attackers, with Contributor-level access and above, to change arbitrary options on affected sites. This can be used to enable new user registration and set the default role for new users to Administrator.","publishedAt":"2024-05-30T10:59:29.483Z","updatedAt":"2026-04-08T16:34:02.520Z","severity":{"score":8.8,"label":"High","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","source":"Wordfence"},"assigner":"Wordfence","products":["wpxpo Post Grid Gutenberg Blocks for News, Magazines, Blog Websites – PostX"],"affected":[{"vendor":"wpxpo","product":"Post Grid Gutenberg Blocks for News, Magazines, Blog Websites – PostX","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"4.1.2","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/07a3db33-3787-4b63-835d-8e3026206842?source=cve","https://plugins.trac.wordpress.org/browser/ultimate-post/trunk/classes/Styles.php#L160","https://plugins.trac.wordpress.org/browser/ultimate-post/trunk/classes/Styles.php#L177","https://plugins.trac.wordpress.org/changeset/3093815/"],"weaknesses":["CWE-862"],"ingestedAt":"2026-10-29T20:08:12.933Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2024/5xxx/CVE-2024-5326.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2024-5326","state":"PUBLISHED","datePublished":"2024-05-30T10:59:29.483Z","dateUpdated":"2026-04-08T16:34:02.520Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2024-05-24T16:37:41.847Z"},"containers":{"cna":{"title":"Post Grid Gutenberg Blocks and WordPress Blog Plugin – PostX <= 4.1.2 - Missing Authorization to Arbitrary Options Update","descriptions":[{"lang":"en","value":"The Post Grid Gutenberg Blocks and WordPress Blog Plugin – PostX plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the 'postx_presets_callback' function in all versions up to, and including, 4.1.2. This makes it possible for authenticated attackers, with Contributor-level access and above, to change arbitrary options on affected sites. This can be used to enable new user registration and set the default role for new users to Administrator."}],"affected":[{"vendor":"wpxpo","product":"Post Grid Gutenberg Blocks for News, Magazines, Blog Websites – PostX","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"4.1.2","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/07a3db33-3787-4b63-835d-8e3026206842?source=cve"},{"url":"https://plugins.trac.wordpress.org/browser/ultimate-post/trunk/classes/Styles.php#L160"},{"url":"https://plugins.trac.wordpress.org/browser/ultimate-post/trunk/classes/Styles.php#L177"},{"url":"https://plugins.trac.wordpress.org/changeset/3093815/"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","baseScore":8.8,"baseSeverity":"HIGH"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-862","lang":"en","description":"CWE-862 Missing Authorization","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T16:34:02.520Z"},"credits":[{"lang":"en","type":"finder","value":"AmrAwad"}],"timeline":[{"time":"2024-05-29T00:00:00.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"id":"CVE-2024-5326","role":"CISA Coordinator","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"total"}],"version":"2.0.3","timestamp":"2024-06-04T15:26:53.899779Z"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2024-06-04T18:01:47.927Z"}},{"title":"CVE Program Container","references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/07a3db33-3787-4b63-835d-8e3026206842?source=cve","tags":["x_transferred"]},{"url":"https://plugins.trac.wordpress.org/browser/ultimate-post/trunk/classes/Styles.php#L160","tags":["x_transferred"]},{"url":"https://plugins.trac.wordpress.org/browser/ultimate-post/trunk/classes/Styles.php#L177","tags":["x_transferred"]},{"url":"https://plugins.trac.wordpress.org/changeset/3093815/","tags":["x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-01T21:11:12.432Z"}}]}}}