{"id":"CVE-2024-50339","state":"PUBLISHED","title":"GLPI vulnerable to unauthenticated session hijacking","description":"GLPI is a free asset and IT management software package. Starting in version 9.5.0 and prior to version 10.0.17, an unauthenticated user can retrieve all the sessions IDs and use them to steal any valid session. Version 10.0.17 contains a patch for this issue.","publishedAt":"2024-12-11T17:48:42.230Z","updatedAt":"2024-12-11T18:31:59.719Z","severity":{"score":9.3,"label":"Critical","version":"4.0","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N","source":"GitHub_M"},"assigner":"GitHub_M","products":["glpi-project glpi"],"affected":[{"vendor":"glpi-project","product":"glpi","versions":[{"version":">= 9.5.0, < 10.0.17","status":"affected"}]}],"references":["https://github.com/glpi-project/glpi/security/advisories/GHSA-v977-g4r9-6r72","https://github.com/glpi-project/glpi/releases/tag/10.0.17"],"weaknesses":["CWE-79","CWE-287"],"ingestedAt":"2026-10-29T20:07:56.516Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2024/50xxx/CVE-2024-50339.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2024-50339","state":"PUBLISHED","datePublished":"2024-12-11T17:48:42.230Z","dateUpdated":"2024-12-11T18:31:59.719Z","assignerShortName":"GitHub_M","assignerOrgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateReserved":"2024-10-22T17:54:40.954Z"},"containers":{"cna":{"title":"GLPI vulnerable to unauthenticated session hijacking","descriptions":[{"lang":"en","value":"GLPI is a free asset and IT management software package. Starting in version 9.5.0 and prior to version 10.0.17, an unauthenticated user can retrieve all the sessions IDs and use them to steal any valid session. Version 10.0.17 contains a patch for this issue."}],"affected":[{"vendor":"glpi-project","product":"glpi","versions":[{"version":">= 9.5.0, < 10.0.17","status":"affected"}]}],"references":[{"url":"https://github.com/glpi-project/glpi/security/advisories/GHSA-v977-g4r9-6r72","name":"https://github.com/glpi-project/glpi/security/advisories/GHSA-v977-g4r9-6r72","tags":["x_refsource_CONFIRM"]},{"url":"https://github.com/glpi-project/glpi/releases/tag/10.0.17","name":"https://github.com/glpi-project/glpi/releases/tag/10.0.17","tags":["x_refsource_MISC"]}],"metrics":[{"cvssV4_0":{"attackVector":"NETWORK","attackComplexity":"LOW","attackRequirements":"NONE","privilegesRequired":"NONE","userInteraction":"NONE","vulnConfidentialityImpact":"HIGH","vulnIntegrityImpact":"HIGH","vulnAvailabilityImpact":"LOW","subConfidentialityImpact":"NONE","subIntegrityImpact":"NONE","subAvailabilityImpact":"NONE","baseScore":9.3,"baseSeverity":"CRITICAL","vectorString":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N","version":"4.0"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","lang":"en","description":"CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","type":"CWE"}]},{"descriptions":[{"cweId":"CWE-287","lang":"en","description":"CWE-287: Improper Authentication","type":"CWE"}]}],"providerMetadata":{"shortName":"GitHub_M","orgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateUpdated":"2024-12-11T17:48:42.230Z"},"source":{"advisory":"GHSA-v977-g4r9-6r72","discovery":"UNKNOWN"}},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2024-12-11T18:31:33.627317Z","id":"CVE-2024-50339","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2024-12-11T18:31:59.719Z"}}]}}}