{"id":"CVE-2024-4564","state":"PUBLISHED","title":"CoDesigner WooCommerce Builder for Elementor – Customize Checkout, Shop, Email, Products & More <= 4.4.1 - Authenticated (Contributor+) Stored Cross-Site Scripting via Multiple Widgets","description":"The CoDesigner WooCommerce Builder for Elementor – Customize Checkout, Shop, Email, Products & More plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's Shop Slider, Tabs Classic, and Image Comparison widgets in all versions up to, and including, 4.4.1 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.","publishedAt":"2024-06-12T03:33:14.904Z","updatedAt":"2026-04-08T16:45:00.243Z","severity":{"score":6.4,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["codexpert CoDesigner – All in One Elementor WooCommerce Builder"],"affected":[{"vendor":"codexpert","product":"CoDesigner – All in One Elementor WooCommerce Builder","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"4.4.1","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/3115e8ad-8e68-41e9-a3a0-5f003d921037?source=cve","https://plugins.trac.wordpress.org/browser/woolementor/trunk/widgets/shop-slider/template.php#L29","https://plugins.trac.wordpress.org/browser/woolementor/trunk/widgets/tabs-classic/tabs-classic.php#L329","https://plugins.trac.wordpress.org/browser/woolementor/trunk/widgets/image-comparison/image-comparison.php#L418","https://plugins.trac.wordpress.org/changeset/3099922/","https://wordpress.org/plugins/woolementor/#developers"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T20:07:56.516Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2024/4xxx/CVE-2024-4564.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2024-4564","state":"PUBLISHED","datePublished":"2024-06-12T03:33:14.904Z","dateUpdated":"2026-04-08T16:45:00.243Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2024-05-06T19:03:09.940Z"},"containers":{"cna":{"title":"CoDesigner WooCommerce Builder for Elementor – Customize Checkout, Shop, Email, Products & More <= 4.4.1 - Authenticated (Contributor+) Stored Cross-Site Scripting via Multiple Widgets","descriptions":[{"lang":"en","value":"The CoDesigner WooCommerce Builder for Elementor – Customize Checkout, Shop, Email, Products & More plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's Shop Slider, Tabs Classic, and Image Comparison widgets in all versions up to, and including, 4.4.1 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page."}],"affected":[{"vendor":"codexpert","product":"CoDesigner – All in One Elementor WooCommerce Builder","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"4.4.1","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/3115e8ad-8e68-41e9-a3a0-5f003d921037?source=cve"},{"url":"https://plugins.trac.wordpress.org/browser/woolementor/trunk/widgets/shop-slider/template.php#L29"},{"url":"https://plugins.trac.wordpress.org/browser/woolementor/trunk/widgets/tabs-classic/tabs-classic.php#L329"},{"url":"https://plugins.trac.wordpress.org/browser/woolementor/trunk/widgets/image-comparison/image-comparison.php#L418"},{"url":"https://plugins.trac.wordpress.org/changeset/3099922/"},{"url":"https://wordpress.org/plugins/woolementor/#developers"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","baseScore":6.4,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","lang":"en","description":"CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T16:45:00.243Z"},"credits":[{"lang":"en","type":"finder","value":"Matthew Rollings"}],"timeline":[{"time":"2024-06-11T15:24:21.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2024-06-12T19:29:20.422092Z","id":"CVE-2024-4564","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2024-06-12T19:29:31.623Z"}},{"title":"CVE Program Container","references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/3115e8ad-8e68-41e9-a3a0-5f003d921037?source=cve","tags":["x_transferred"]},{"url":"https://plugins.trac.wordpress.org/browser/woolementor/trunk/widgets/shop-slider/template.php#L29","tags":["x_transferred"]},{"url":"https://plugins.trac.wordpress.org/browser/woolementor/trunk/widgets/tabs-classic/tabs-classic.php#L329","tags":["x_transferred"]},{"url":"https://plugins.trac.wordpress.org/browser/woolementor/trunk/widgets/image-comparison/image-comparison.php#L418","tags":["x_transferred"]},{"url":"https://plugins.trac.wordpress.org/changeset/3099922/","tags":["x_transferred"]},{"url":"https://wordpress.org/plugins/woolementor/#developers","tags":["x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-01T20:47:40.983Z"}}]}}}