{"id":"CVE-2024-4334","state":"PUBLISHED","title":"Supreme Modules Lite – Divi Theme, Extra Theme and Divi Builder <= 2.5.3 - Authenticated (Contributor+) DOM-Based Cross-Site Scripting","description":"The Supreme Modules Lite – Divi Theme, Extra Theme and Divi Builder plugin for WordPress is vulnerable to DOM-Based Cross-Site Scripting via the ‘typing_cursor’ parameter in versions up to, and including, 2.5.3 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.","publishedAt":"2024-05-02T16:51:49.677Z","updatedAt":"2026-04-08T16:37:22.002Z","severity":{"score":6.4,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["divisupreme Supreme Modules Lite – Divi Theme, Extra Theme and Divi Builder"],"affected":[{"vendor":"divisupreme","product":"Supreme Modules Lite – Divi Theme, Extra Theme and Divi Builder","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"2.5.3","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/17508063-3cd7-4b61-b7be-23a71b75f6a2?source=cve","https://plugins.trac.wordpress.org/browser/supreme-modules-for-divi/trunk/includes/modules/TypingEffect/TypingEffect.php#L744","https://plugins.trac.wordpress.org/browser/supreme-modules-for-divi/trunk/includes/modules/TypingEffect/frontend.min.js","https://plugins.trac.wordpress.org/changeset/3079965/#file203","https://plugins.trac.wordpress.org/changeset/3079965/#file204"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T20:07:56.516Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2024/4xxx/CVE-2024-4334.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2024-4334","state":"PUBLISHED","datePublished":"2024-05-02T16:51:49.677Z","dateUpdated":"2026-04-08T16:37:22.002Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2024-04-30T00:21:01.378Z"},"containers":{"cna":{"title":"Supreme Modules Lite – Divi Theme, Extra Theme and Divi Builder <= 2.5.3 - Authenticated (Contributor+) DOM-Based Cross-Site Scripting","descriptions":[{"lang":"en","value":"The Supreme Modules Lite – Divi Theme, Extra Theme and Divi Builder plugin for WordPress is vulnerable to DOM-Based Cross-Site Scripting via the ‘typing_cursor’ parameter in versions up to, and including, 2.5.3 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page."}],"affected":[{"vendor":"divisupreme","product":"Supreme Modules Lite – Divi Theme, Extra Theme and Divi Builder","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"2.5.3","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/17508063-3cd7-4b61-b7be-23a71b75f6a2?source=cve"},{"url":"https://plugins.trac.wordpress.org/browser/supreme-modules-for-divi/trunk/includes/modules/TypingEffect/TypingEffect.php#L744"},{"url":"https://plugins.trac.wordpress.org/browser/supreme-modules-for-divi/trunk/includes/modules/TypingEffect/frontend.min.js"},{"url":"https://plugins.trac.wordpress.org/changeset/3079965/#file203"},{"url":"https://plugins.trac.wordpress.org/changeset/3079965/#file204"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","baseScore":6.4,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","lang":"en","description":"CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T16:37:22.002Z"},"credits":[{"lang":"en","type":"finder","value":"Craig Smith"}],"timeline":[{"time":"2024-05-01T00:00:00.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"id":"CVE-2024-4334","role":"CISA Coordinator","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"version":"2.0.3","timestamp":"2024-05-02T20:23:04.219062Z"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2024-06-04T17:55:43.934Z"}},{"title":"CVE Program Container","references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/17508063-3cd7-4b61-b7be-23a71b75f6a2?source=cve","tags":["x_transferred"]},{"url":"https://plugins.trac.wordpress.org/browser/supreme-modules-for-divi/trunk/includes/modules/TypingEffect/TypingEffect.php#L744","tags":["x_transferred"]},{"url":"https://plugins.trac.wordpress.org/browser/supreme-modules-for-divi/trunk/includes/modules/TypingEffect/frontend.min.js","tags":["x_transferred"]},{"url":"https://plugins.trac.wordpress.org/changeset/3079965/#file203","tags":["x_transferred"]},{"url":"https://plugins.trac.wordpress.org/changeset/3079965/#file204","tags":["x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-01T20:40:47.072Z"}}]}}}