{"id":"CVE-2024-42473","state":"PUBLISHED","title":"OpenFGA Authorization Bypass","description":"OpenFGA is an authorization/permission engine. OpenFGA v1.5.7 and v1.5.8 are vulnerable to authorization bypass when calling Check API with a model that uses `but not` and `from` expressions and a userset. Users should downgrade to v1.5.6 as soon as possible. This downgrade is backward compatible. As of time of publication, a patch is not available but OpenFGA's maintainers are planning a patch for inclusion in a future release.","publishedAt":"2024-08-09T21:16:17.683Z","updatedAt":"2024-08-10T14:21:04.103Z","severity":{"score":7.5,"label":"High","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N","source":"GitHub_M"},"assigner":"GitHub_M","products":["openfga openfga"],"affected":[{"vendor":"openfga","product":"openfga","versions":[{"version":">=1.5.7, <= 1.5.8","status":"affected"}]}],"references":["https://github.com/openfga/openfga/security/advisories/GHSA-3f6g-m4hr-59h8"],"weaknesses":["CWE-863"],"ingestedAt":"2026-10-29T20:07:47.831Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2024/42xxx/CVE-2024-42473.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2024-42473","state":"PUBLISHED","datePublished":"2024-08-09T21:16:17.683Z","dateUpdated":"2024-08-10T14:21:04.103Z","assignerShortName":"GitHub_M","assignerOrgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateReserved":"2024-08-02T14:13:04.615Z"},"containers":{"cna":{"title":"OpenFGA Authorization Bypass","descriptions":[{"lang":"en","value":"OpenFGA is an authorization/permission engine. OpenFGA v1.5.7 and v1.5.8 are vulnerable to authorization bypass when calling Check API with a model that uses `but not` and `from` expressions and a userset. Users should downgrade to v1.5.6 as soon as possible. This downgrade is backward compatible. As of time of publication, a patch is not available but OpenFGA's maintainers are planning a patch for inclusion in a future release."}],"affected":[{"vendor":"openfga","product":"openfga","versions":[{"version":">=1.5.7, <= 1.5.8","status":"affected"}]}],"references":[{"url":"https://github.com/openfga/openfga/security/advisories/GHSA-3f6g-m4hr-59h8","name":"https://github.com/openfga/openfga/security/advisories/GHSA-3f6g-m4hr-59h8","tags":["x_refsource_CONFIRM"]}],"metrics":[{"cvssV3_1":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"NONE","baseScore":7.5,"baseSeverity":"HIGH","confidentialityImpact":"NONE","integrityImpact":"HIGH","privilegesRequired":"NONE","scope":"UNCHANGED","userInteraction":"NONE","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.1"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-863","lang":"en","description":"CWE-863: Incorrect Authorization","type":"CWE"}]}],"providerMetadata":{"shortName":"GitHub_M","orgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateUpdated":"2024-08-09T21:16:17.683Z"},"source":{"advisory":"GHSA-3f6g-m4hr-59h8","discovery":"UNKNOWN"}},"adp":[{"title":"CISA ADP Vulnrichment","affected":[{"vendor":"openfga","product":"openfga","defaultStatus":"unknown","versions":[{"version":"1.5.7","status":"affected","lessThanOrEqual":"1.5.8","versionType":"custom"}],"cpes":["cpe:2.3:a:openfga:openfga:*:*:*:*:*:*:*:*"]}],"metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2024-08-10T14:18:27.056147Z","id":"CVE-2024-42473","options":[{"Exploitation":"none"},{"Automatable":"yes"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2024-08-10T14:21:04.103Z"}}]}}}