{"id":"CVE-2024-41816","state":"PUBLISHED","title":"WordPress Cooked Plugin Persistent Cross-Site Scripting via Shortcode","description":"Cooked is a recipe plugin for WordPress. The Cooked plugin for WordPress is vulnerable to Persistent Cross-Site Scripting (XSS) via the ‘[cooked-timer]’ shortcode in versions up to, and including, 1.8.0 due to insufficient input sanitization and output escaping. This vulnerability allows authenticated attackers with subscriber-level access and above to inject arbitrary web scripts in pages that will execute whenever a user accesses a compromised page. This issue has been addressed in release version 1.8.1. All users are advised to upgrade. There are no known workarounds for this vulnerability.","publishedAt":"2024-08-05T20:12:41.428Z","updatedAt":"2024-08-08T13:28:33.622Z","severity":{"score":5.4,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","source":"GitHub_M"},"assigner":"GitHub_M","products":["XjSv Cooked"],"affected":[{"vendor":"XjSv","product":"Cooked","versions":[{"version":"< 1.8.1","status":"affected"}]}],"references":["https://github.com/XjSv/Cooked/security/advisories/GHSA-3gw3-2qjq-xqjj","https://github.com/XjSv/Cooked/commit/ac7455bdccc99fb2f5b3c7611312947c1623c3ec"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T20:07:39.287Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2024/41xxx/CVE-2024-41816.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2024-41816","state":"PUBLISHED","datePublished":"2024-08-05T20:12:41.428Z","dateUpdated":"2024-08-08T13:28:33.622Z","assignerShortName":"GitHub_M","assignerOrgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateReserved":"2024-07-22T13:57:37.137Z"},"containers":{"cna":{"title":"WordPress Cooked Plugin Persistent Cross-Site Scripting via Shortcode","descriptions":[{"lang":"en","value":"Cooked is a recipe plugin for WordPress. The Cooked plugin for WordPress is vulnerable to Persistent Cross-Site Scripting (XSS) via the ‘[cooked-timer]’ shortcode in versions up to, and including, 1.8.0 due to insufficient input sanitization and output escaping. This vulnerability allows authenticated attackers with subscriber-level access and above to inject arbitrary web scripts in pages that will execute whenever a user accesses a compromised page. This issue has been addressed in release version 1.8.1. All users are advised to upgrade. There are no known workarounds for this vulnerability."}],"affected":[{"vendor":"XjSv","product":"Cooked","versions":[{"version":"< 1.8.1","status":"affected"}]}],"references":[{"url":"https://github.com/XjSv/Cooked/security/advisories/GHSA-3gw3-2qjq-xqjj","name":"https://github.com/XjSv/Cooked/security/advisories/GHSA-3gw3-2qjq-xqjj","tags":["x_refsource_CONFIRM"]},{"url":"https://github.com/XjSv/Cooked/commit/ac7455bdccc99fb2f5b3c7611312947c1623c3ec","name":"https://github.com/XjSv/Cooked/commit/ac7455bdccc99fb2f5b3c7611312947c1623c3ec","tags":["x_refsource_MISC"]}],"metrics":[{"cvssV3_1":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"NONE","baseScore":5.4,"baseSeverity":"MEDIUM","confidentialityImpact":"LOW","integrityImpact":"LOW","privilegesRequired":"LOW","scope":"CHANGED","userInteraction":"REQUIRED","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","lang":"en","description":"CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","type":"CWE"}]}],"providerMetadata":{"shortName":"GitHub_M","orgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateUpdated":"2024-08-05T20:12:41.428Z"},"source":{"advisory":"GHSA-3gw3-2qjq-xqjj","discovery":"UNKNOWN"}},"adp":[{"title":"CISA ADP Vulnrichment","affected":[{"vendor":"goratech","product":"cooked","defaultStatus":"unknown","versions":[{"version":"0","status":"affected","lessThan":"1.8.1","versionType":"custom"}],"cpes":["cpe:2.3:a:goratech:cooked:*:*:*:*:*:*:*:*"]}],"metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2024-08-08T13:26:56.709952Z","id":"CVE-2024-41816","options":[{"Exploitation":"poc"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2024-08-08T13:28:33.622Z"}}]}}}