{"id":"CVE-2024-4045","state":"PUBLISHED","title":"Popup Builder by OptinMonster – WordPress Popups for Optins, Email Newsletters and Lead Generation <= 2.16.1 - Authenticated (Contributor+) Stored Cross-Site Scripting","description":"The Popup Builder by OptinMonster – WordPress Popups for Optins, Email Newsletters and Lead Generation plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘campaign_id’ parameter in versions up to, and including, 2.16.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.","publishedAt":"2024-05-25T05:36:43.663Z","updatedAt":"2026-04-08T17:17:05.757Z","severity":{"score":6.4,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["smub Popup Builder & Popup Maker for WordPress – OptinMonster Email Marketing and Lead Generation"],"affected":[{"vendor":"smub","product":"Popup Builder & Popup Maker for WordPress – OptinMonster Email Marketing and Lead Generation","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"2.16.1","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/b4dfeb49-38d3-495d-af96-d67a29b339fa?source=cve","https://plugins.trac.wordpress.org/browser/optinmonster/tags/2.16.0/OMAPI/Elementor/Widget.php#L532","https://plugins.trac.wordpress.org/changeset/3087905/"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T20:07:56.516Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2024/4xxx/CVE-2024-4045.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2024-4045","state":"PUBLISHED","datePublished":"2024-05-25T05:36:43.663Z","dateUpdated":"2026-04-08T17:17:05.757Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2024-04-22T23:26:59.374Z"},"containers":{"cna":{"title":"Popup Builder by OptinMonster – WordPress Popups for Optins, Email Newsletters and Lead Generation <= 2.16.1 - Authenticated (Contributor+) Stored Cross-Site Scripting","descriptions":[{"lang":"en","value":"The Popup Builder by OptinMonster – WordPress Popups for Optins, Email Newsletters and Lead Generation plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘campaign_id’ parameter in versions up to, and including, 2.16.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page."}],"affected":[{"vendor":"smub","product":"Popup Builder & Popup Maker for WordPress – OptinMonster Email Marketing and Lead Generation","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"2.16.1","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/b4dfeb49-38d3-495d-af96-d67a29b339fa?source=cve"},{"url":"https://plugins.trac.wordpress.org/browser/optinmonster/tags/2.16.0/OMAPI/Elementor/Widget.php#L532"},{"url":"https://plugins.trac.wordpress.org/changeset/3087905/"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","baseScore":6.4,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","lang":"en","description":"CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T17:17:05.757Z"},"credits":[{"lang":"en","type":"finder","value":"wesley"}],"timeline":[{"time":"2024-05-24T16:30:44.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"id":"CVE-2024-4045","role":"CISA Coordinator","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"version":"2.0.3","timestamp":"2024-05-26T13:50:50.331048Z"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2024-06-04T17:54:20.540Z"}},{"title":"CVE Program Container","references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/b4dfeb49-38d3-495d-af96-d67a29b339fa?source=cve","tags":["x_transferred"]},{"url":"https://plugins.trac.wordpress.org/browser/optinmonster/tags/2.16.0/OMAPI/Elementor/Widget.php#L532","tags":["x_transferred"]},{"url":"https://plugins.trac.wordpress.org/changeset/3087905/","tags":["x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-01T20:26:57.273Z"}}]}}}