{"id":"CVE-2024-39311","state":"PUBLISHED","title":"Publify Vulnerable To Cross-Site Scripting (XSS) Via Redirects Requiring User Interaction","description":"Publify is a self hosted Web publishing platform on Rails. Prior to version 10.0.1 of Publify, corresponding to versions prior to 10.0.2 of the `publify_core` rubygem, publisher on a `publify` application is able to perform a cross-site scripting (XSS) attack on an administrator using the redirect functionality. The exploitation of this XSS vulnerability requires the administrator to click a malicious link. An attack could attempt to hide their payload by using HTML, or other encodings, as to not make it obvious to an administrator that this is a malicious link. A publisher may attempt to use this vulnerability to escalate their privileges and become an administrator. Version 10.0.1 of Publify and version 10.0.2 of the `publify_core` rubygem fix the issue.","publishedAt":"2025-03-28T14:38:03.816Z","updatedAt":"2025-03-28T15:37:35.064Z","severity":{"score":1.8,"label":"Low","version":"4.0","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:P","source":"GitHub_M"},"assigner":"GitHub_M","products":["publify publify"],"affected":[{"vendor":"publify","product":"publify","versions":[{"version":"< 10.0.1","status":"affected"}]}],"references":["https://github.com/publify/publify/security/advisories/GHSA-8fm5-gg2f-f66q"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T20:07:39.287Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2024/39xxx/CVE-2024-39311.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2024-39311","state":"PUBLISHED","datePublished":"2025-03-28T14:38:03.816Z","dateUpdated":"2025-03-28T15:37:35.064Z","assignerShortName":"GitHub_M","assignerOrgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateReserved":"2024-06-21T18:15:22.260Z"},"containers":{"cna":{"title":"Publify Vulnerable To Cross-Site Scripting (XSS) Via Redirects Requiring User Interaction","descriptions":[{"lang":"en","value":"Publify is a self hosted Web publishing platform on Rails. Prior to version 10.0.1 of Publify, corresponding to versions prior to 10.0.2 of the `publify_core` rubygem, publisher on a `publify` application is able to perform a cross-site scripting (XSS) attack on an administrator using the redirect functionality. The exploitation of this XSS vulnerability requires the administrator to click a malicious link. An attack could attempt to hide their payload by using HTML, or other encodings, as to not make it obvious to an administrator that this is a malicious link. A publisher may attempt to use this vulnerability to escalate their privileges and become an administrator. Version 10.0.1 of Publify and version 10.0.2 of the `publify_core` rubygem fix the issue."}],"affected":[{"vendor":"publify","product":"publify","versions":[{"version":"< 10.0.1","status":"affected"}]}],"references":[{"url":"https://github.com/publify/publify/security/advisories/GHSA-8fm5-gg2f-f66q","name":"https://github.com/publify/publify/security/advisories/GHSA-8fm5-gg2f-f66q","tags":["x_refsource_CONFIRM"]}],"metrics":[{"cvssV4_0":{"attackVector":"NETWORK","attackComplexity":"LOW","attackRequirements":"NONE","privilegesRequired":"HIGH","userInteraction":"ACTIVE","vulnConfidentialityImpact":"NONE","vulnIntegrityImpact":"NONE","vulnAvailabilityImpact":"NONE","subConfidentialityImpact":"LOW","subIntegrityImpact":"LOW","subAvailabilityImpact":"NONE","baseScore":1.8,"baseSeverity":"LOW","vectorString":"CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:P","version":"4.0"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","lang":"en","description":"CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","type":"CWE"}]}],"providerMetadata":{"shortName":"GitHub_M","orgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateUpdated":"2025-03-28T14:38:03.816Z"},"source":{"advisory":"GHSA-8fm5-gg2f-f66q","discovery":"UNKNOWN"}},"adp":[{"title":"CISA ADP Vulnrichment","references":[{"url":"https://github.com/publify/publify/security/advisories/GHSA-8fm5-gg2f-f66q","tags":["exploit"]}],"metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-03-28T15:37:13.196294Z","id":"CVE-2024-39311","options":[{"Exploitation":"poc"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-03-28T15:37:35.064Z"}}]}}}