{"id":"CVE-2024-32564","state":"PUBLISHED","title":"WordPress PostX plugin <= 4.0.1 - Cross Site Scripting (XSS) vulnerability","description":"Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WPXPO PostX ultimate-post allows DOM-Based XSS.This issue affects PostX: from n/a through <= 4.0.1.","publishedAt":"2024-04-18T09:56:05.367Z","updatedAt":"2026-04-28T16:09:37.354Z","severity":{"score":6.5,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L","source":"Patchstack"},"assigner":"Patchstack","products":["WPXPO PostX"],"affected":[{"vendor":"WPXPO","product":"PostX","packageName":"ultimate-post","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"4.0.1","changes":[{"at":"4.0.2","status":"unaffected"}],"versionType":"custom"}],"collectionURL":"https://wordpress.org/plugins"}],"references":["https://patchstack.com/database/Wordpress/Plugin/ultimate-post/vulnerability/wordpress-post-grid-blocks-and-wordpress-news-plugin-postx-plugin-4-0-1-cross-site-scripting-xss-vulnerability?_s_id=cve","https://patchstack.com/database/vulnerability/ultimate-post/wordpress-post-grid-blocks-and-wordpress-news-plugin-postx-plugin-4-0-1-cross-site-scripting-xss-vulnerability?_s_id=cve"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T20:07:21.467Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2024/32xxx/CVE-2024-32564.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2024-32564","state":"PUBLISHED","datePublished":"2024-04-18T09:56:05.367Z","dateUpdated":"2026-04-28T16:09:37.354Z","assignerShortName":"Patchstack","assignerOrgId":"21595511-bba5-4825-b968-b78d1f9984a3","dateReserved":"2024-04-15T09:14:12.747Z"},"containers":{"cna":{"title":"WordPress PostX plugin <= 4.0.1 - Cross Site Scripting (XSS) vulnerability","descriptions":[{"lang":"en","value":"Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WPXPO PostX ultimate-post allows DOM-Based XSS.This issue affects PostX: from n/a through <= 4.0.1."}],"affected":[{"vendor":"WPXPO","product":"PostX","packageName":"ultimate-post","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"4.0.1","changes":[{"at":"4.0.2","status":"unaffected"}],"versionType":"custom"}],"collectionURL":"https://wordpress.org/plugins"}],"references":[{"url":"https://patchstack.com/database/Wordpress/Plugin/ultimate-post/vulnerability/wordpress-post-grid-blocks-and-wordpress-news-plugin-postx-plugin-4-0-1-cross-site-scripting-xss-vulnerability?_s_id=cve","tags":["vdb-entry"]}],"metrics":[{"cvssV3_1":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"LOW","baseScore":6.5,"baseSeverity":"MEDIUM","confidentialityImpact":"LOW","integrityImpact":"LOW","privilegesRequired":"LOW","scope":"CHANGED","userInteraction":"REQUIRED","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L","version":"3.1"},"format":"CVSS","scenarios":[{"lang":"en","value":"GENERAL"}]}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","description":"Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"Patchstack","orgId":"21595511-bba5-4825-b968-b78d1f9984a3","dateUpdated":"2026-04-28T16:09:37.354Z"},"credits":[{"lang":"en","type":"finder","value":"CatFather | Patchstack Bug Bounty Program"}],"datePublic":"2026-04-01T16:25:06.990Z","impacts":[{"capecId":"CAPEC-588","descriptions":[{"lang":"en","value":"DOM-Based XSS"}]}]},"adp":[{"title":"CISA ADP Vulnrichment","affected":[{"vendor":"post_grid_team_by_wpxpo","product":"postx-gutenberg_blocks_for_post_grid","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"4.0.1","versionType":"custom"}],"cpes":["cpe:2.3:a:post_grid_team_by_wpxpo:postx-gutenberg_blocks_for_post_grid:*:*:*:*:*:*:*:*"]}],"metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2024-06-07T20:31:19.529413Z","id":"CVE-2024-32564","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2024-06-07T20:33:42.111Z"}},{"title":"CVE Program Container","references":[{"url":"https://patchstack.com/database/vulnerability/ultimate-post/wordpress-post-grid-blocks-and-wordpress-news-plugin-postx-plugin-4-0-1-cross-site-scripting-xss-vulnerability?_s_id=cve","tags":["vdb-entry","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-02T02:13:40.097Z"}}]}}}