{"id":"CVE-2024-31929","state":"PUBLISHED","title":"WordPress Intagrate Lite plugin <= 1.3.7 - Cross Site Scripting (XSS) vulnerability","description":"Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Iain Poulson Intagrate Lite instagrate-to-wordpress.This issue affects Intagrate Lite: from n/a through <= 1.3.7.","publishedAt":"2024-04-11T12:26:47.098Z","updatedAt":"2026-04-28T16:09:32.892Z","severity":{"score":5.9,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:L","source":"Patchstack"},"assigner":"Patchstack","products":["Iain Poulson Intagrate Lite"],"affected":[{"vendor":"Iain Poulson","product":"Intagrate Lite","packageName":"instagrate-to-wordpress","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"1.3.7","changes":[{"at":"1.3.8","status":"unaffected"}],"versionType":"custom"}],"collectionURL":"https://wordpress.org/plugins"}],"references":["https://patchstack.com/database/Wordpress/Plugin/instagrate-to-wordpress/vulnerability/wordpress-intagrate-lite-plugin-1-3-7-cross-site-scripting-xss-vulnerability?_s_id=cve","https://patchstack.com/database/vulnerability/instagrate-to-wordpress/wordpress-intagrate-lite-plugin-1-3-7-cross-site-scripting-xss-vulnerability?_s_id=cve"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T20:07:21.467Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2024/31xxx/CVE-2024-31929.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2024-31929","state":"PUBLISHED","datePublished":"2024-04-11T12:26:47.098Z","dateUpdated":"2026-04-28T16:09:32.892Z","assignerShortName":"Patchstack","assignerOrgId":"21595511-bba5-4825-b968-b78d1f9984a3","dateReserved":"2024-04-07T18:10:46.764Z"},"containers":{"cna":{"title":"WordPress Intagrate Lite plugin <= 1.3.7 - Cross Site Scripting (XSS) vulnerability","descriptions":[{"lang":"en","value":"Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Iain Poulson Intagrate Lite instagrate-to-wordpress.This issue affects Intagrate Lite: from n/a through <= 1.3.7."}],"affected":[{"vendor":"Iain Poulson","product":"Intagrate Lite","packageName":"instagrate-to-wordpress","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"1.3.7","changes":[{"at":"1.3.8","status":"unaffected"}],"versionType":"custom"}],"collectionURL":"https://wordpress.org/plugins"}],"references":[{"url":"https://patchstack.com/database/Wordpress/Plugin/instagrate-to-wordpress/vulnerability/wordpress-intagrate-lite-plugin-1-3-7-cross-site-scripting-xss-vulnerability?_s_id=cve","tags":["vdb-entry"]}],"metrics":[{"cvssV3_1":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"LOW","baseScore":5.9,"baseSeverity":"MEDIUM","confidentialityImpact":"LOW","integrityImpact":"LOW","privilegesRequired":"HIGH","scope":"CHANGED","userInteraction":"REQUIRED","vectorString":"CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:L","version":"3.1"},"format":"CVSS","scenarios":[{"lang":"en","value":"GENERAL"}]}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","description":"Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"Patchstack","orgId":"21595511-bba5-4825-b968-b78d1f9984a3","dateUpdated":"2026-04-28T16:09:32.892Z"},"credits":[{"lang":"en","type":"finder","value":"Joshua Chan | Patchstack Bug Bounty Program"}],"datePublic":"2026-04-01T16:24:44.518Z"},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"id":"CVE-2024-31929","role":"CISA Coordinator","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"version":"2.0.3","timestamp":"2024-04-11T13:50:16.180138Z"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2024-06-04T17:36:13.067Z"}},{"title":"CVE Program Container","references":[{"url":"https://patchstack.com/database/vulnerability/instagrate-to-wordpress/wordpress-intagrate-lite-plugin-1-3-7-cross-site-scripting-xss-vulnerability?_s_id=cve","tags":["vdb-entry","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-02T01:59:50.619Z"}}]}}}