{"id":"CVE-2024-3187","state":"PUBLISHED","title":"This issue tracks two CWE-416 Use After Free (UAF) and one CWE-415 Double Free vulnerabilities in Goahead versions <= 6.0.0. These are caused by JST values not being nulled when fr","description":"This issue tracks two CWE-416 Use After Free (UAF) and one CWE-415 Double Free vulnerabilities in Goahead versions <= 6.0.0. These are caused by JST values not being nulled when freed during parsing of JST templates. If the ME_GOAHEAD_JAVASCRIPT flag is enabled, a remote attacker with the privileges to modify JavaScript template (JST) files could exploit this by providing malicious templates. This may lead to memory corruption, potentially causing a Denial of Service (DoS) or, in rare cases, code execution, though the latter is highly context-dependent.","publishedAt":"2024-10-17T07:34:50.960Z","updatedAt":"2024-10-17T14:40:42.458Z","severity":{"score":5.9,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:H","source":"Nozomi"},"assigner":"Nozomi","products":["EmbedThis GoAhead"],"affected":[{"vendor":"EmbedThis","product":"GoAhead","defaultStatus":"unknown","versions":[{"version":"0","status":"affected","lessThanOrEqual":"6.0.0","versionType":"semver"}],"repo":"https://www.embedthis.com/goahead/download.html"}],"references":["https://www.nozominetworks.com/labs/vulnerability-advisories-cve-2024-3187"],"weaknesses":["CWE-416","CWE-415"],"ingestedAt":"2026-10-29T20:07:39.287Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2024/3xxx/CVE-2024-3187.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2024-3187","state":"PUBLISHED","datePublished":"2024-10-17T07:34:50.960Z","dateUpdated":"2024-10-17T14:40:42.458Z","assignerShortName":"Nozomi","assignerOrgId":"bec8025f-a851-46e5-b3a3-058e6b0aa23c","dateReserved":"2024-04-02T13:02:32.106Z"},"containers":{"cna":{"descriptions":[{"lang":"en","value":"This issue tracks two CWE-416 Use After Free (UAF) and one CWE-415 Double Free vulnerabilities in Goahead versions <= 6.0.0. These are caused by JST values not being nulled when freed during parsing of JST templates. If the ME_GOAHEAD_JAVASCRIPT flag is enabled, a remote attacker with the privileges to modify JavaScript template (JST) files could exploit this by providing malicious templates. This may lead to memory corruption, potentially causing a Denial of Service (DoS) or, in rare cases, code execution, though the latter is highly context-dependent."}],"affected":[{"vendor":"EmbedThis","product":"GoAhead","defaultStatus":"unknown","versions":[{"version":"0","status":"affected","lessThanOrEqual":"6.0.0","versionType":"semver"}],"repo":"https://www.embedthis.com/goahead/download.html"}],"references":[{"url":"https://www.nozominetworks.com/labs/vulnerability-advisories-cve-2024-3187"}],"metrics":[{"cvssV3_1":{"attackComplexity":"HIGH","attackVector":"NETWORK","availabilityImpact":"HIGH","baseScore":5.9,"baseSeverity":"MEDIUM","confidentialityImpact":"NONE","integrityImpact":"LOW","privilegesRequired":"LOW","scope":"UNCHANGED","userInteraction":"NONE","vectorString":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:H","version":"3.1"},"format":"CVSS","scenarios":[{"lang":"en","value":"GENERAL"}]}],"problemTypes":[{"descriptions":[{"cweId":"CWE-416","description":"CWE-416 Use After Free","lang":"en","type":"CWE"}]},{"descriptions":[{"cweId":"CWE-415","description":"CWE-415 Double Free","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"Nozomi","orgId":"bec8025f-a851-46e5-b3a3-058e6b0aa23c","dateUpdated":"2024-10-17T07:34:50.960Z"},"credits":[{"lang":"en","type":"finder","user":"00000000-0000-4000-9000-000000000000","value":"Diego Zaffaroni of Nozomi Networks found this bug during a security research activity."}],"solutions":[{"lang":"en","supportingMedia":[{"base64":false,"type":"text/html","value":"It is recommended to apply fixes introduced in version 6.0.1 of GoAhead and use the latest version available as base for building custom web servers."}],"value":"It is recommended to apply fixes introduced in version 6.0.1 of GoAhead and use the latest version available as base for building custom web servers."}],"source":{"discovery":"EXTERNAL"},"x_generator":{"engine":"Vulnogram 0.1.0-dev"}},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2024-10-17T14:40:32.549079Z","id":"CVE-2024-3187","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2024-10-17T14:40:42.458Z"}}]}}}