{"id":"CVE-2024-31227","state":"PUBLISHED","title":"Denial-of-service due to malformed ACL selectors in Redis","description":"Redis is an open source, in-memory database that persists on disk. An authenticated with sufficient privileges may create a malformed ACL selector which, when accessed, triggers a server panic and subsequent denial of service. The problem exists in Redis 7 prior to versions 7.2.6 and 7.4.1. Users are advised to upgrade. There are no known workarounds for this vulnerability.","publishedAt":"2024-10-07T19:51:04.520Z","updatedAt":"2024-10-07T20:20:56.702Z","severity":{"score":4.4,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H","source":"GitHub_M"},"assigner":"GitHub_M","products":["redis redis"],"affected":[{"vendor":"redis","product":"redis","versions":[{"version":">= 7.0.0, < 7.2.6","status":"affected"},{"version":">= 7.3.0, < 7.4.1","status":"affected"}]}],"references":["https://github.com/redis/redis/security/advisories/GHSA-38p4-26x2-vqhh","https://github.com/redis/redis/commit/b351d5a3210e61cc3b22ba38a723d6da8f3c298a"],"weaknesses":["CWE-20"],"ingestedAt":"2026-10-29T20:07:21.467Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2024/31xxx/CVE-2024-31227.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2024-31227","state":"PUBLISHED","datePublished":"2024-10-07T19:51:04.520Z","dateUpdated":"2024-10-07T20:20:56.702Z","assignerShortName":"GitHub_M","assignerOrgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateReserved":"2024-03-29T14:16:31.902Z"},"containers":{"cna":{"title":"Denial-of-service due to malformed ACL selectors in Redis","descriptions":[{"lang":"en","value":"Redis is an open source, in-memory database that persists on disk. An authenticated with sufficient privileges may create a malformed ACL selector which, when accessed, triggers a server panic and subsequent denial of service. The problem exists in Redis 7 prior to versions 7.2.6 and 7.4.1. Users are advised to upgrade. There are no known workarounds for this vulnerability."}],"affected":[{"vendor":"redis","product":"redis","versions":[{"version":">= 7.0.0, < 7.2.6","status":"affected"},{"version":">= 7.3.0, < 7.4.1","status":"affected"}]}],"references":[{"url":"https://github.com/redis/redis/security/advisories/GHSA-38p4-26x2-vqhh","name":"https://github.com/redis/redis/security/advisories/GHSA-38p4-26x2-vqhh","tags":["x_refsource_CONFIRM"]},{"url":"https://github.com/redis/redis/commit/b351d5a3210e61cc3b22ba38a723d6da8f3c298a","name":"https://github.com/redis/redis/commit/b351d5a3210e61cc3b22ba38a723d6da8f3c298a","tags":["x_refsource_MISC"]}],"metrics":[{"cvssV3_1":{"attackComplexity":"LOW","attackVector":"LOCAL","availabilityImpact":"HIGH","baseScore":4.4,"baseSeverity":"MEDIUM","confidentialityImpact":"NONE","integrityImpact":"NONE","privilegesRequired":"HIGH","scope":"UNCHANGED","userInteraction":"NONE","vectorString":"CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H","version":"3.1"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-20","lang":"en","description":"CWE-20: Improper Input Validation","type":"CWE"}]}],"providerMetadata":{"shortName":"GitHub_M","orgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateUpdated":"2024-10-07T19:51:04.520Z"},"source":{"advisory":"GHSA-38p4-26x2-vqhh","discovery":"UNKNOWN"}},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2024-10-07T20:20:44.399182Z","id":"CVE-2024-31227","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2024-10-07T20:20:56.702Z"}}]}}}